aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2012-10-12 23:40:29 +0000
committerGerald Combs <gerald@wireshark.org>2012-10-12 23:40:29 +0000
commitcfa22deaae3169b3bca9fd4cd9c564d391531bb0 (patch)
tree9ae2671a2c61b6a3bbf23e2f8097a6a34270f713 /ui/qt/CMakeLists.txt
parentc91c1df500cc3950cc7a375aaae72f20ea0eb652 (diff)
Add a packet format group box, similar to the packet range group box.
Use it in the new "Export Packet Dissections" dialog. I'm omitting PostScript exports on purpose. If you *really* need that feature you can probably get better results than we produce using text + enscript or print-to-PDF + pdf2ps/pdftops or PSML/PDML + XSL + ... The Windows code is untested. I'll check in any needed fixes shortly. svn path=/trunk/; revision=45513
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index e6a01d76f2..a671f95616 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -33,6 +33,7 @@ set(QTSHARK_H_SRC
color_utils.h
display_filter_combo.h
display_filter_edit.h
+ export_dissection_dialog.h
file_set_dialog.h
import_text_dialog.h
interface_tree.h
@@ -41,6 +42,7 @@ set(QTSHARK_H_SRC
main_welcome.h
main_window.h
monospace_font.h
+ packet_format_group_box.h
packet_list.h
packet_list_model.h
packet_range_group_box.h
@@ -66,6 +68,7 @@ set(QTSHARK_CPP_SRC
color_utils.cpp
display_filter_combo.cpp
display_filter_edit.cpp
+ export_dissection_dialog.cpp
file_set_dialog.cpp
import_text_dialog.cpp
interface_tree.cpp
@@ -76,6 +79,7 @@ set(QTSHARK_CPP_SRC
main_window.cpp
main_window_slots.cpp
monospace_font.cpp
+ packet_format_group_box.cpp
packet_list.cpp
packet_list_model.cpp
packet_list_record.cpp
@@ -99,6 +103,7 @@ set(QTSHARK_UI
import_text_dialog.ui
main_welcome.ui
main_window.ui
+ packet_format_group_box.ui
packet_range_group_box.ui
)