aboutsummaryrefslogtreecommitdiffstats
path: root/ui/gtk/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2015-06-16 17:07:04 -0400
committerMichael Mann <mmann78@netscape.net>2015-06-21 03:35:13 +0000
commit6de6f7f0f8f8b79c4fc7473c7e54dad433c7b61b (patch)
tree20b4b81b49467f5685f51c6b75e240c41ca6cb32 /ui/gtk/CMakeLists.txt
parent2895d58dc38321a72c82e1bf77d165ef4acbc73a (diff)
Further refactor SRT stats.
Create "common" SRT tap data collection intended for all GUIs. Refactor/merge functionality of existing dissectors that have SRT support (AFP, DCERPC, Diameter, FC, GTP, LDAP, NCP, RPC, SCIS, SMB, and SMB2) for both TShark and GTK. SMB and DCERPC "tap packet filtering" were different between TShark and GTK, so I went with GTK filter logic. CAMEL "tap packet filtering" was different between TShark and GTK, so GTK filtering logic was pushed to the dissector and the TShark tap was left alone. Change-Id: I7d6eaad0673fe628ef337f9165d7ed94f4a5e1cc Reviewed-on: https://code.wireshark.org/review/8894 Petri-Dish: Michael Mann <mmann78@netscape.net> Reviewed-by: Gerald Combs <gerald@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'ui/gtk/CMakeLists.txt')
-rw-r--r--ui/gtk/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/ui/gtk/CMakeLists.txt b/ui/gtk/CMakeLists.txt
index 6a02968a8e..147bad3271 100644
--- a/ui/gtk/CMakeLists.txt
+++ b/ui/gtk/CMakeLists.txt
@@ -195,37 +195,30 @@ if(ENABLE_EXTCAP)
endif()
set(WIRESHARK_TAP_SRC
- afp_stat.c
ansi_a_stat.c
ansi_map_stat.c
bootp_stat.c
camel_counter.c
- camel_srt.c
compare_stat.c
dcerpc_stat.c
- diameter_stat.c
expert_comp_dlg.c
- fc_stat.c
flow_graph.c
funnel_stat.c
gsm_a_stat.c
gsm_map_stat.c
gsm_map_summary.c
- gtp_stat.c
h225_counter.c
h225_ras_srt.c
iax2_analysis.c
io_stat.c
lbm_stream_dlg.c
lbm_uimflow_dlg.c
- ldap_stat.c
mac_lte_stat_dlg.c
mcast_stream_dlg.c
megaco_stat.c
mgcp_stat.c
mtp3_stat.c
mtp3_summary.c
- ncp_stat.c
radius_stat.c
rlc_lte_graph.c
rlc_lte_stat_dlg.c
@@ -233,14 +226,11 @@ set(WIRESHARK_TAP_SRC
rpc_stat.c
rtp_analysis.c
rtp_stream_dlg.c
- scsi_stat.c
sctp_assoc_analyse.c
sctp_chunk_stat.c
sctp_chunk_stat_dlg.c
sctp_stat_dlg.c
sip_stat.c
- smb_stat.c
- smb2_stat.c
stats_tree_stat.c
tcp_graph.c
voip_calls_dlg.c