aboutsummaryrefslogtreecommitdiffstats
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2012-09-14 20:23:18 +0000
committerGerald Combs <gerald@wireshark.org>2012-09-14 20:23:18 +0000
commit762e5ac93f08912c6daae6e83033b01332e914ab (patch)
treeb7782b13f2ffe300f89dd3144a341b33afd4c363 /ui/CMakeLists.txt
parent670dff46e451ca0e701bdafb5c13d75c42b261f6 (diff)
Create a common libui using CMake similar to what we do with Autotools.
Move the GTK+ text import code to the common UI directory. Create wtap_encap_requires_phdr() from code in file_import_dlg.c. svn path=/trunk/; revision=44904
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
new file mode 100644
index 0000000000..dbe08cffc7
--- /dev/null
+++ b/ui/CMakeLists.txt
@@ -0,0 +1,53 @@
+# CMakeLists.txt
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+#
+
+
+set(COMMON_UI_SRC
+ alert_box.c
+ iface_lists.c
+ text_import.c
+ util.c
+)
+
+set(CLEAN_FILES
+ ${COMMON_UI_SRC}
+)
+
+add_lex_files(COMMON_UI_SRC
+ text_import_scanner.l
+)
+
+if (WERROR)
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS -Werror
+ )
+endif()
+
+
+add_library(ui STATIC
+ ${COMMON_UI_SRC}
+)
+
+set_target_properties(ui PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")