aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/wimaxasncp/Makefile.am
diff options
context:
space:
mode:
authorMartin Mathieson <martin.r.mathieson@googlemail.com>2007-10-12 09:59:10 +0000
committerMartin Mathieson <martin.r.mathieson@googlemail.com>2007-10-12 09:59:10 +0000
commit358c4399ba193157b580eea16fb32c9319e78016 (patch)
tree60031ce53a99a91195f4460c5bd6296af5b27892 /plugins/wimaxasncp/Makefile.am
parent2e37539cd55ec1cd1f8888c40af0f91437b142b0 (diff)
TLVs now defined in XML (from Stephen Croll).
svn path=/trunk/; revision=23156
Diffstat (limited to 'plugins/wimaxasncp/Makefile.am')
-rw-r--r--plugins/wimaxasncp/Makefile.am28
1 files changed, 24 insertions, 4 deletions
diff --git a/plugins/wimaxasncp/Makefile.am b/plugins/wimaxasncp/Makefile.am
index a5883caebd..a68a327f76 100644
--- a/plugins/wimaxasncp/Makefile.am
+++ b/plugins/wimaxasncp/Makefile.am
@@ -22,6 +22,9 @@
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#
+# lex rules
+include ../../Makefile.am.inc
+
INCLUDES = -I$(top_srcdir) -I$(includedir)
include Makefile.common
@@ -115,11 +118,28 @@ CLEANFILES = \
*~
MAINTAINERCLEANFILES = \
- Makefile.in \
+ Makefile.in \
+ wimaxasncp_dict.c \
+ wimaxasncp_dict_lex.h \
plugin.c
EXTRA_DIST = \
- Makefile.common \
- Makefile.nmake \
- moduleinfo.nmake \
+ wimaxasncp_dict.l \
+ Makefile.common \
+ Makefile.nmake \
+ moduleinfo.nmake \
plugin.rc.in
+
+RUNLEX = $(top_srcdir)/tools/runlex.sh
+
+wimaxasncp_dict_lex.h : wimaxasncp_dict.c
+
+#
+# Install the wimaxasncp DTD and XML files in the "wimaxasncp"
+# subdirectory of $(pkgdatadir)
+#
+
+wimaxasncpdir = $(pkgdatadir)/wimaxasncp
+wimaxasncp_DATA = \
+ dictionary.dtd \
+ dictionary.xml