aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/wimax/Makefile.am
diff options
context:
space:
mode:
authorgerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2007-05-25 23:40:42 +0000
committergerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2007-05-25 23:40:42 +0000
commitc2dd45d5185ed1cb26012290a8dd3b6174c927c1 (patch)
tree3f899da6a2bb6dead6dbfa2392764a88ac26faa6 /plugins/wimax/Makefile.am
parent5b2f879d81286215d2dc460a9cf42ce71e889102 (diff)
From Mike Harvey: Support for WiMAX and the WiMAX M2M encapsulation protocol.
Add support for WiMAX and M2M to various makefiles and installer files. Add basic support for M2M to randpkt. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@21945 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'plugins/wimax/Makefile.am')
-rw-r--r--plugins/wimax/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/plugins/wimax/Makefile.am b/plugins/wimax/Makefile.am
new file mode 100644
index 0000000000..3bf4f0dc93
--- /dev/null
+++ b/plugins/wimax/Makefile.am
@@ -0,0 +1,56 @@
+# Makefile.am
+# Automake file for Wireshark WiMax Plugin
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@ethereal.com>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+INCLUDES = -I$(top_srcdir)
+
+plugindir = @plugindir@
+
+plugin_LTLIBRARIES = wimax.la
+wimax_la_SOURCES = packet-wmx.c wimax_ffb_decoder.c wimax_fch_decoder.c wimax_pdu_decoder.c\
+ wimax_cdma_code_decoder.c wimax_hack_decoder.c wimax_phy_attributes_decoder.c \
+ mac_hd_generic_decoder.c mac_hd_type1_decoder.c mac_hd_type2_decoder.c \
+ mac_mgmt_msg_decoder.c msg_dcd.c msg_ucd.c msg_dlmap.c msg_ulmap.c \
+ msg_rng_req.c msg_rng_rsp.c msg_reg_req.c msg_reg_rsp.c msg_dreg.c \
+ msg_dsa.c msg_dsc.c msg_dsd.c msg_arq.c msg_sbc.c msg_pkm.c msg_aas_fbck.c \
+ msg_fpc.c msg_pmc.c msg_prc_lt_ctrl.c msg_aas_beam.c msg_res_cmd.c msg_rep.c \
+ msg_clk_cmp.c msg_dsx_rvd.c wimax_harq_map_decoder.c \
+ wimax_compact_dlmap_ie_decoder.c wimax_compact_ulmap_ie_decoder.c \
+ wimax_utils.c crc.c crc_data.c wimax_tlv.c moduleinfo.h
+wimax_la_LDFLAGS = -module -avoid-version
+wimax_la_LIBADD = @PLUGIN_LIBS@
+
+# Libs must be cleared, or else libtool won't create a shared module.
+# If your module needs to be linked against any particular libraries,
+# add them here.
+LIBS =
+
+CLEANFILES = \
+ wimax \
+ *~
+
+MAINTAINERCLEANFILES = \
+ Makefile.in
+
+EXTRA_DIST = \
+ Makefile.nmake