aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/tpg/CMakeLists.txt
diff options
context:
space:
mode:
authorjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2010-03-18 10:27:17 +0000
committerjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2010-03-18 10:27:17 +0000
commitd1b2a85437eea4deaa23bf6944e69c67208d76eb (patch)
tree447b5cb2f49d91c4f87cd170ac0fe6f6b032117a /plugins/tpg/CMakeLists.txt
parent66eb2e219eaf33e61aded4b03b29ccce22ae499a (diff)
cmake changes:
- Add checking for linker flags - Install plugins with the name including the Wireshark version. This will make it easier to find matching plugin versions if files get just copied over. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@32231 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'plugins/tpg/CMakeLists.txt')
-rw-r--r--plugins/tpg/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/tpg/CMakeLists.txt b/plugins/tpg/CMakeLists.txt
index 68086a0abd..a2bf906daa 100644
--- a/plugins/tpg/CMakeLists.txt
+++ b/plugins/tpg/CMakeLists.txt
@@ -74,12 +74,13 @@ add_library(tpg ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(tpg PROPERTIES PREFIX "")
-#set_target_properties(tpg PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(tpg PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
+set_target_properties(tpg PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(tpg epan)
install(TARGETS tpg
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)