aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/tpg/CMakeLists.txt
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2010-09-24 20:41:34 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2010-09-24 20:41:34 +0000
commitacd821a13fe9b76a7178d1644f2687c631799477 (patch)
treec6918a98de58abd1144cd9002f1a4c3c43dc815c /plugins/tpg/CMakeLists.txt
parent41bcd25194a0928d9312f84d53834aa0fe1a2d92 (diff)
Plugins are not shared libraries, so:
1) don't set thei SOVERSION - run-time-loaded modules don't have an SOVERSION; 2) build them with link mode MODULE, not SHARED, on all platforms. (Fixing 1) also fixes the problem with building them as MODULE on OS X.) git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@34243 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'plugins/tpg/CMakeLists.txt')
-rw-r--r--plugins/tpg/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/plugins/tpg/CMakeLists.txt b/plugins/tpg/CMakeLists.txt
index a2bf906daa..22110fe7dc 100644
--- a/plugins/tpg/CMakeLists.txt
+++ b/plugins/tpg/CMakeLists.txt
@@ -74,7 +74,6 @@ add_library(tpg ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(tpg PROPERTIES PREFIX "")
-set_target_properties(tpg PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
set_target_properties(tpg PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
target_link_libraries(tpg epan)