aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/tpg/CMakeLists.txt
diff options
context:
space:
mode:
authorjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2009-09-25 18:09:42 +0000
committerjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2009-09-25 18:09:42 +0000
commit14afdc70fee3eb5ac1d3fa994097af53ddcf5cc2 (patch)
tree7d41a5f97cca6020fa1aee90cc3aedbfab17b876 /plugins/tpg/CMakeLists.txt
parent33b36f78e6a666eaf7cf8830a2806c887e9d4792 (diff)
Try to add tpg, but it seems it doesn't build with autofoo either.
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@30151 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'plugins/tpg/CMakeLists.txt')
-rw-r--r--plugins/tpg/CMakeLists.txt74
1 files changed, 74 insertions, 0 deletions
diff --git a/plugins/tpg/CMakeLists.txt b/plugins/tpg/CMakeLists.txt
new file mode 100644
index 0000000000..c6106df8eb
--- /dev/null
+++ b/plugins/tpg/CMakeLists.txt
@@ -0,0 +1,74 @@
+# CMakeLists.txt
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+set(PLUGIN_FILES
+ http-parser.c
+ packet-http.c
+)
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+set(_tpg ${CMAKE_SOURCE_DIR}/tools/tpg)
+
+ADD_CUSTOM_COMMAND(
+ OUTPUT
+ TPG.pm
+ COMMAND ${YAPP_EXECUTABLE}
+ -v
+ -m TPG
+ ${_tpg}/tpg.yp
+ DEPENDS
+ ${_tpg}/tpg.yp
+
+)
+
+ADD_CUSTOM_COMMAND(
+ OUTPUT
+ http-parser.h
+ http-parser.c
+ COMMAND ${PERL_EXECUTABLE}
+ -I${CMAKE_BINARY_DIR}
+ -I${_tpg}
+ ${_tpg}/tpg.pl
+ ${CMAKE_CURRENT_SOURCE_DIR}/http.tpg
+ DEPENDS
+ ${_tpg}/tpg.pl
+ TPG.pm
+ ${_tpg}/V2P.pm
+ ${CMAKE_CURRENT_SOURCE_DIR}/http.tpg
+)
+
+# todo
+# Do I need any of this or is this handled by type MODULE?
+# asn1_la_LDFLAGS = -module -avoid-version
+
+add_library(tpg MODULE
+ ${PLUGIN_FILES}
+)
+
+install(TARGETS tpg
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+)
+