aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/stats_tree/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-02-09 05:31:15 +0000
committerGuy Harris <guy@alum.mit.edu>2013-02-09 05:31:15 +0000
commite30d2b5001ae68f7d71e20f290f5a6116243994f (patch)
tree2d000509f1b77ca60727b9d7340df7b73128ad80 /plugins/stats_tree/Makefile.am
parent4aae84271d346f95a68225aefd84207aa4505679 (diff)
Make the other plugin makefiles use the new style introduced in the MATE
makefiles. svn path=/trunk/; revision=47579
Diffstat (limited to 'plugins/stats_tree/Makefile.am')
-rw-r--r--plugins/stats_tree/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/plugins/stats_tree/Makefile.am b/plugins/stats_tree/Makefile.am
index c5092e5501..e33efafebd 100644
--- a/plugins/stats_tree/Makefile.am
+++ b/plugins/stats_tree/Makefile.am
@@ -22,6 +22,8 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
+include $(top_srcdir)/Makefile.am.inc
+
INCLUDES = -I$(top_srcdir)
include Makefile.common
@@ -33,7 +35,11 @@ endif
plugindir = @plugindir@
plugin_LTLIBRARIES = stats_tree.la
-stats_tree_la_SOURCES = $(TAP_SRC) $(TAP_INCLUDES)
+
+stats_tree_la_SOURCES = \
+ $(SRC_FILES) \
+ $(HEADER_FILES)
+
stats_tree_la_LDFLAGS = -module -avoid-version
stats_tree_la_LIBADD = @PLUGIN_LIBS@
@@ -47,8 +53,7 @@ CLEANFILES = \
*~
MAINTAINERCLEANFILES = \
- Makefile.in \
- plugin.c
+ Makefile.in
EXTRA_DIST = \
Makefile.common \
@@ -58,4 +63,5 @@ EXTRA_DIST = \
CMakeLists.txt
checkapi:
- $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput -build $(TAP_SRC) $(TAP_INCLUDES)
+ $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput -build \
+ $(CLEAN_SRC_FILES) $(CLEAN_HEADER_FILES)