aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/rudp/Makefile.am
diff options
context:
space:
mode:
authorOlivier Biot <obiot.ethereal@gmail.com>2004-04-14 22:13:28 +0000
committerOlivier Biot <obiot.ethereal@gmail.com>2004-04-14 22:13:28 +0000
commit4459d9f0a9706a576942da662b04837c0f63ead7 (patch)
treea86bab7032fe22711bb6efc77233c372ad81584c /plugins/rudp/Makefile.am
parentaf4a73a52329318d6a120eab009eb8fdb0dc5949 (diff)
Add support for plugin dissectors on cygwin builds, by adding the following
line to every Makefile.am file for a given plugin XXX: XXX_la_LIBADD = -L../../epan -lethereal @GLIB_LIBS@ This way symbols defined in libethereal and GLib are resolved when linking the plugin dissector modules. svn path=/trunk/; revision=10601
Diffstat (limited to 'plugins/rudp/Makefile.am')
-rw-r--r--plugins/rudp/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/plugins/rudp/Makefile.am b/plugins/rudp/Makefile.am
index b681bf0eb5..e3b7d17fc3 100644
--- a/plugins/rudp/Makefile.am
+++ b/plugins/rudp/Makefile.am
@@ -2,7 +2,7 @@
# Automake file for Cisco SS7 Reliable UDP dissector
# Copyright 2004, Duncan Sargeant <dunc-ethereal@rcpt.to>
#
-# $Id: Makefile.am,v 1.1 2004/03/25 11:21:07 guy Exp $
+# $Id: Makefile.am,v 1.2 2004/04/14 22:13:28 obiot Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@ethereal.com>
@@ -30,6 +30,7 @@ plugindir = @plugindir@
plugin_LTLIBRARIES = rudp.la
rudp_la_SOURCES = packet-rudp.c moduleinfo.h
rudp_la_LDFLAGS = -module -avoid-version
+rudp_la_LIBADD = -L../../epan -lethereal @GLIB_LIBS@
# Libs must be cleared, or else libtool won't create a shared module.
# If your module needs to be linked against any particular libraries,