aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mate/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2008-07-29 22:06:37 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2008-07-29 22:06:37 +0000
commitb4d2c376354ff8b9484a4bb1bda937b3d38a4504 (patch)
tree7121af156e058e033d7397202567ca6f8b51c543 /plugins/mate/Makefile.am
parent91cd5cce238799c5a5f1e9b6d7ecdfd7f5c82445 (diff)
Allow checkapis target to work in out-of-tree builds (s#../../#$(top_srcdir)).
Also use $(top_builddir) instead of ../../ in a couple of other spots. svn path=/trunk/; revision=25863
Diffstat (limited to 'plugins/mate/Makefile.am')
-rw-r--r--plugins/mate/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/plugins/mate/Makefile.am b/plugins/mate/Makefile.am
index 13edc84a3d..3a4dd298d9 100644
--- a/plugins/mate/Makefile.am
+++ b/plugins/mate/Makefile.am
@@ -22,7 +22,7 @@
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#
-include ../../Makefile.am.inc
+include $(top_srcdir)/Makefile.am.inc
INCLUDES = -I$(top_srcdir)
@@ -137,7 +137,7 @@ RUNLEX = $(top_srcdir)/tools/runlex.sh
mate_parser_lex.h : mate_parser.c
-LEMON = ../../tools/lemon
+LEMON = $(top_builddir)/tools/lemon
mate_grammar.h : mate_grammar.c
mate_grammar.c : mate_grammar.lemon mate.h mate_util.h $(LEMON)/lemon$(EXEEXT)
@@ -145,4 +145,4 @@ mate_grammar.c : mate_grammar.lemon mate.h mate_util.h $(LEMON)/lemon$(EXEEXT)
(rm -f grammar.c grammar.h ; false)
checkapi:
- $(PERL) ../../tools/checkAPIs.pl -g abort -g termoutput $(DISSECTOR_SRC)
+ $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput $(DISSECTOR_SRC)