aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/epan/falco_bridge/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2022-04-13 13:49:15 -0700
committerGerald Combs <gerald@wireshark.org>2022-04-13 13:51:06 -0700
commit8528fca055b713d097a6baf5163eccaaf96f313c (patch)
treed01fb2ae92d12857128c6ff09386149b827b437e /plugins/epan/falco_bridge/CMakeLists.txt
parent943c38d606643886a707a9c8367e8087e043c2e5 (diff)
Falco Bridge: Misc cleanup.
Remove unused header definitions in packet-falco-bridge.h and move the remaining content to packet-falco-bridge.c and conversation-macros.h. Explicitly set our header files in CMakeLists.txt.
Diffstat (limited to 'plugins/epan/falco_bridge/CMakeLists.txt')
-rw-r--r--plugins/epan/falco_bridge/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugins/epan/falco_bridge/CMakeLists.txt b/plugins/epan/falco_bridge/CMakeLists.txt
index a3bbe796f4..974220865b 100644
--- a/plugins/epan/falco_bridge/CMakeLists.txt
+++ b/plugins/epan/falco_bridge/CMakeLists.txt
@@ -17,6 +17,11 @@ set(DISSECTOR_SRC
sinsp-span.cpp
)
+set(DISSECTOR_HEADERS
+ conversation-macros.h
+ sinsp-span.h
+)
+
set(PLUGIN_FILES
plugin.c
${DISSECTOR_SRC}
@@ -52,7 +57,6 @@ target_link_libraries(falco-bridge
install_plugin(falco-bridge epan)
-file(GLOB DISSECTOR_HEADERS RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "*.h")
CHECKAPI(
NAME
falco-bridge