aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/docsis/Makefile.am
diff options
context:
space:
mode:
authorAnders Broman <anders.broman@ericsson.com>2006-02-01 05:44:20 +0000
committerAnders Broman <anders.broman@ericsson.com>2006-02-01 05:44:20 +0000
commite5e25269c9c11fc05ade2581ad7996439b45a208 (patch)
tree064917225b87406fd18c4f8dc7cd7107aa44d474 /plugins/docsis/Makefile.am
parentc8dd927e0c6dd23f065c965f08e4921ed2635fda (diff)
From Eric Hultin:
This patch adds support for dissection of the DCC packet as defined in CableLab's (http://www.cablelabs.com/) DOCSIS Radio Frequency Interface (RFI) specification. The latest version of this specification is currently available at http://www.cablemodem.com/specifications/specifications20.html . Packet formats for DCC are defined in sections 8.3.20 (DCC-REQ), 8.3.21 (DCC-RSP), and 8.3.22 (DCC-ACK) of the RFI specifications (referencing version CM-SP-RFIv2.0-I10-051209). In addition, this patch adds support for the DCD packet as defined in the DOCSIS Set-Top Gateway (DSG) Specification. The latest version of this specification is currently available at http://www.cablemodem.com/specifications/gateway.html . The format of the DCD packet is defined in section 5.3.1 of the DSG specification (referencing version CM-SP-DSG-I06-051209). svn path=/trunk/; revision=17138
Diffstat (limited to 'plugins/docsis/Makefile.am')
-rw-r--r--plugins/docsis/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/docsis/Makefile.am b/plugins/docsis/Makefile.am
index ea91755def..26468dfd5d 100644
--- a/plugins/docsis/Makefile.am
+++ b/plugins/docsis/Makefile.am
@@ -27,7 +27,7 @@ INCLUDES = -I$(top_srcdir) -I$(includedir)
plugindir = @plugindir@
plugin_LTLIBRARIES = docsis.la
-docsis_la_SOURCES = packet-intrngreq.c packet-type29ucd.c packet-docsis.c packet-bpkmattr.c packet-dsarsp.c packet-macmgmt.c packet-rngrsp.c packet-bpkmreq.c packet-dscack.c packet-map.c packet-tlv.c packet-bpkmrsp.c packet-dscreq.c packet-regack.c packet-uccreq.c packet-dscrsp.c packet-regreq.c packet-uccrsp.c packet-dsaack.c packet-dsdreq.c packet-regrsp.c packet-ucd.c packet-dsareq.c packet-dsdrsp.c packet-rngreq.c packet-vendor.c packet-docsis.h packet-tlv.h moduleinfo.h
+docsis_la_SOURCES = packet-intrngreq.c packet-type29ucd.c packet-docsis.c packet-bpkmattr.c packet-dsarsp.c packet-macmgmt.c packet-rngrsp.c packet-bpkmreq.c packet-dscack.c packet-map.c packet-tlv.c packet-bpkmrsp.c packet-dscreq.c packet-regack.c packet-uccreq.c packet-dscrsp.c packet-regreq.c packet-uccrsp.c packet-dsaack.c packet-dsdreq.c packet-regrsp.c packet-ucd.c packet-dsareq.c packet-dsdrsp.c packet-rngreq.c packet-vendor.c packet-docsis.h packet-tlv.h moduleinfo.h packet-dccack.c packet-dccreq.c packet-dccrsp.c packet-dcd.c
docsis_la_LDFLAGS = -module -avoid-version
docsis_la_LIBADD = @PLUGIN_LIBS@