aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2002-05-05 00:16:38 +0000
committerGuy Harris <guy@alum.mit.edu>2002-05-05 00:16:38 +0000
commiteb70c97a9bd9f362a3e2f888dd082c5b9b4b9516 (patch)
treee3b201865b9c3108cf90f7953b3c85c4dad0066e /plugins/Makefile.am
parent82e11eb8eef35974a5c07658009561390720bfad (diff)
Make a "tcp_dissect_pdus()" with the standard loop for a TCP segment,
extracting PDUs from it and possibly doing reassembly. Make the COPS, DNS, DSI, Gryphon, and SCCP dissectors use it. Add "set_actual_length()", "tcp_dissect_pdus()", "decode_boolean_bitfield()", "decode_numeric_bitfield()", and "decode_enumerated_bitfield()" to the list of routines available to dissectors on platforms where routines in the main program aren't available to dynamically-loaded code. Declare routines in "to_str.h" as "extern"; as I remember, that's necessary to allow the "decode_XXX_bitfield()" routines declared therein to be made available to plugins as per the above. Note that new exported routines should be added to the end of the table if that's the only change being made to the table. Create a new "plugin_api_decls.h" header file, used to declare both the "p_" variables and the "p_" structure members in the routine-exporting mechanism; this reduces the number of places you have to change to change the list of exported routines. svn path=/trunk/; revision=5394
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index f4c28806a0..83338ea000 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.8 2001/10/31 10:40:54 guy Exp $
+# $Id: Makefile.am,v 1.9 2002/05/05 00:16:36 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -29,6 +29,7 @@ plugindir = @PLUGIN_DIR@
EXTRA_DIST = \
plugin_api.c \
plugin_api.h \
+ plugin_api_decls.h \
plugin_api_defs.h \
plugin_table.h \
Makefile.nmake