aboutsummaryrefslogtreecommitdiffstats
path: root/packaging/wix/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-07-23 13:47:35 -0700
committerGerald Combs <gerald@wireshark.org>2018-07-24 17:16:08 +0000
commitf3de00fc36eb86f4485352db4dc98030bf896eb4 (patch)
treecf24e541d0373b52c90d1dd1380eb11b07e541bd /packaging/wix/CMakeLists.txt
parent4bd0978f9c9b625d189998bb08812a289eef9d55 (diff)
CMake: Fixup some documentation dependencies.
Change the dependencies of various wsug targets to update_tools_help instead of the files it generates. Have the nsis_package_prep and wix_package_prep targets depend on user_guide_chm instead of update_tools_help. This should make parallel builds of all_guides, wix_package_prep and possibly other targets more reliable. Change-Id: I473f0e608aade1ac0053c03bef0942c69c650f65 Reviewed-on: https://code.wireshark.org/review/28838 Petri-Dish: Gerald Combs <gerald@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'packaging/wix/CMakeLists.txt')
-rw-r--r--packaging/wix/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/packaging/wix/CMakeLists.txt b/packaging/wix/CMakeLists.txt
index e571ad6158..e9297848d8 100644
--- a/packaging/wix/CMakeLists.txt
+++ b/packaging/wix/CMakeLists.txt
@@ -271,9 +271,7 @@ macro( ADD_WIX_PACKAGE_TARGET )
DEPENDS
${WIX_FILES}
copy_data_files
- update_tools_help
- user_guides
- ${CMAKE_BINARY_DIR}/docbook/user-guide.chm
+ user_guide_chm
)
set_target_properties(wix_package_prep PROPERTIES FOLDER "Packaging")