aboutsummaryrefslogtreecommitdiffstats
path: root/packaging/wix/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2020-01-06 09:58:38 -0800
committerGerald Combs <gerald@wireshark.org>2020-01-06 19:50:50 +0000
commit7a09c78f123b5dd1237000726f19e2801edeaf39 (patch)
treef22a656841a463d52039b352380f5261031d57e9 /packaging/wix/CMakeLists.txt
parent05d772ce7b40008dcb99f492aece86507166c233 (diff)
NSIS: Don't package .pdb files.
We run `windeployqt ... --pdbs` at build time, which means that we need to be careful not to include them in the NSIS package. Switch from using wildcards ("File ...\*") to using separate "File" commands for each file. Simplify the PDB Zip package command while we're here. Bug: 16307 Change-Id: Ibd9bcbdfdc216f1f6a067baf711bbc184845143f Reviewed-on: https://code.wireshark.org/review/35670 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'packaging/wix/CMakeLists.txt')
-rw-r--r--packaging/wix/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/packaging/wix/CMakeLists.txt b/packaging/wix/CMakeLists.txt
index df8070431f..ba89480b62 100644
--- a/packaging/wix/CMakeLists.txt
+++ b/packaging/wix/CMakeLists.txt
@@ -266,6 +266,7 @@ macro( ADD_WIX_PACKAGE_TARGET )
COMMAND ${POWERSHELL_COMMAND} "${_wix_source_dir}/windeployqt-to-wix.ps1"
-Executable $<TARGET_FILE:wireshark>
-FilePath ${_wix_binary_dir}/QtDependentComponents.wxs
+ DEPENDS "${_wix_source_dir}/windeployqt-to-wix.ps1"
)
# SNMPMibs.wxs. Collects all MIBs in "output" snmp/mibs