aboutsummaryrefslogtreecommitdiffstats
path: root/packaging/wix/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2019-02-15 17:00:52 -0800
committerGuy Harris <guy@alum.mit.edu>2019-02-16 02:31:14 +0000
commit7770ad93e27519fd3fb56d88cc51a8dfc729799a (patch)
treeecc859dc06701cec14f729b83b0b0c9cb66bef0d /packaging/wix/CMakeLists.txt
parent751ab080eb89caebdf62452ab0ef072e0f88bbf7 (diff)
Don't allow NSIS or WiX installers if we aren't building Wireshark.
In both cases, a file used in the process of building the installer is generated from the Wireshark binary, so, unless we also arrange not to put that file in the installer if Wireshark isn't being built, we can't build the installer. Have ADD_NSIS_PACKAGE_TARGET and ADD_WIX_PACKAGE_TARGET check whether we're building Wireshark and fail if we aren't. That way, *if* we're including the NSIS or WiX packages in the build files, we fail if we aren't building Wireshark. Change-Id: Icfe4d2491bd721cdd5fef424e9a7565c4990defa Reviewed-on: https://code.wireshark.org/review/32053 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'packaging/wix/CMakeLists.txt')
-rw-r--r--packaging/wix/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/packaging/wix/CMakeLists.txt b/packaging/wix/CMakeLists.txt
index 7011f0f7ef..d1db7c2bdf 100644
--- a/packaging/wix/CMakeLists.txt
+++ b/packaging/wix/CMakeLists.txt
@@ -221,6 +221,17 @@ macro( ADD_WIX_PACKAGE_TARGET )
set (_wix_binary_dir ${CMAKE_BINARY_DIR}/packaging/wix )
# QtDependentComponents.wxs. Created using Wireshark.exe.
+ #
+ # XXX - if we're not building Wireshark, we can't build this
+ # manifest. On the other hand, if we're not building
+ # Wireshark, we have no need to include Qt in the installer,
+ # so it's not clear we need this manifest.
+ #
+ # This should probably be fixed, so that people can produce
+ # command-line-only installer packages.
+ if(NOT BUILD_wireshark)
+ message(FATAL_ERROR "The WiX installer cannot be built if the Wireshark program isn't built.")
+ endif()
add_custom_command(OUTPUT ${_wix_binary_dir}/QtDependentComponents.wxs
COMMAND set "PATH=${QT_BIN_PATH};%PATH%"
COMMAND ${POWERSHELL_COMMAND} "${_wix_source_dir}/windeployqt-to-wix.ps1"