aboutsummaryrefslogtreecommitdiffstats
path: root/packaging/wix/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-11-01 20:22:32 +0000
committerJoão Valverde <j@v6e.pt>2017-11-19 20:16:50 +0000
commit262a84c384353b2a88a6e81cdc499ab94a8316c2 (patch)
tree759ed52d7d81ce9e5ef21e338d235f94f53d77b0 /packaging/wix/CMakeLists.txt
parent61bd626d5d10a7cd0e2dac667bbb262452fe906f (diff)
Fix (and chop) static build option
This sets the scope of the static build option to Wireshark support libraries only. Before the patch: Static plugins don't work with CMake and autotools. autotools static build is broken, and most likely will always be, as building Wireshark all-static is difficult and time-consuming. After the patch: For CMake Wireshark will be built with static or shared libraries and dynamic plugins. Everything just works. CMake apparently doesn't want you building static and shared libraries at the same time. For autotools Wireshark will be built with shared libraries by default. --disable-shared and --enable-static options work as usual. Dlopened plugins are not built if --disable-shared is given to configure (to disable shared libraries). This is a limitations imposed by libtool. Tested on Linux. This removes broken support for building plugins statically. Change-Id: Ib8e8176976f136eea93a2ce8f9857b6cf9bec64c Reviewed-on: https://code.wireshark.org/review/24241 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'packaging/wix/CMakeLists.txt')
-rw-r--r--packaging/wix/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/packaging/wix/CMakeLists.txt b/packaging/wix/CMakeLists.txt
index cc976f3dd5..386678bf61 100644
--- a/packaging/wix/CMakeLists.txt
+++ b/packaging/wix/CMakeLists.txt
@@ -123,11 +123,6 @@ find_path(MERGE_MODULE_DIR ${MERGE_MODULE}
message(STATUS "Using ${MERGE_MODULE_DIR}/Microsoft_${MSVC_CRT_VERSION}_CRT_${TARGET_MACHINE}.msm for the installer")
-if(NOT ENABLE_STATIC)
- # XXX Replace ENABLE_LIBWIRESHARK with !ENABLE_STATIC everywhere.
- set(ENABLE_LIBWIRESHARK "-dENABLE_LIBWIRESHARK")
-endif()
-
# DependentComponents.wxi. Can be created at configure time.
set(_all_manifest_wix "${CMAKE_CURRENT_BINARY_DIR}/DependentComponents.wxs")
file(WRITE "${_all_manifest_wix}" "<?xml version=\"1.0\" encoding=\"utf-8\"?>\n")
@@ -321,7 +316,6 @@ set(WIX_CANDLE_DEFINES
-dVCRedistDir=${MERGE_MODULE_DIR}
${use_gtk}
${use_smi}
- ${ENABLE_LIBWIRESHARK}
-arch ${TARGET_MACHINE}
-ext WixUIExtension
-I${CMAKE_SOURCE_DIR}/packaging/wix