aboutsummaryrefslogtreecommitdiffstats
path: root/packaging/nsis/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-02-11 14:24:18 -0800
committerGerald Combs <gerald@wireshark.org>2019-02-14 23:11:15 +0000
commit23c9a1e036445c17ec4bbc5d0fcbea4f588253c1 (patch)
tree37fa8cffa8ae7a2fd2cf42e3a1d85749ec3a40f3 /packaging/nsis/CMakeLists.txt
parentef0ef16c30a8a217645e06df47eb4e5718dabb0b (diff)
Convert the FAQ to Asciidoctor and remove old help files.
Convert our self-generating FAQ to Asciidoctor via the following steps: - `help/faq.py > /tmp/faq.html`. - `pandoc -t asciidoc -o docbook/faq.adoc /tmp/faq.html`. - Manually clean up the markup using a text editor. Question and answer content was left intact. Removing or updating obsolete content will have to be done in a separate change. The Asciidoctor project uses the .adoc extension, so start using it here as well. The contents of the "help" directory appear to have been used for offline support in help_url.c, but that functionality was removed in 2008 in 242e3b78bc. Its content is covered in the User's Guide and man pages so remove it. Change-Id: I9060eefe97cfc137f8b414077c30f814379b576a Reviewed-on: https://code.wireshark.org/review/32014 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'packaging/nsis/CMakeLists.txt')
-rw-r--r--packaging/nsis/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/packaging/nsis/CMakeLists.txt b/packaging/nsis/CMakeLists.txt
index 1a5a8aec9a..1439de94ff 100644
--- a/packaging/nsis/CMakeLists.txt
+++ b/packaging/nsis/CMakeLists.txt
@@ -35,7 +35,7 @@ set(PROGRAM_NAME ${CMAKE_PROJECT_NAME})
file(TO_NATIVE_PATH "${CMAKE_SOURCE_DIR}" TOP_SRC_DIR)
# STAGING_DIR depends on the build configuration so we pass it
# on the command line below.
-file(TO_NATIVE_PATH "${CMAKE_BINARY_DIR}/docbook" USER_GUIDE_DIR)
+file(TO_NATIVE_PATH "${CMAKE_BINARY_DIR}/docbook" DOCBOOK_DIR)
if(WIRESHARK_TARGET_PLATFORM STREQUAL "win32")
set(TARGET_MACHINE x86)
elseif(WIRESHARK_TARGET_PLATFORM STREQUAL "win64")
@@ -204,6 +204,7 @@ macro( ADD_NSIS_PACKAGE_TARGET )
${NSIS_FILES}
copy_data_files
user_guide_chm
+ faq_html
${DATAFILE_DIR}/uninstall.exe
)
set_target_properties(nsis_package_prep PROPERTIES FOLDER "Packaging")