aboutsummaryrefslogtreecommitdiffstats
path: root/libltdl/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>1999-12-26 22:38:07 +0000
committerGerald Combs <gerald@wireshark.org>1999-12-26 22:38:07 +0000
commit45babe7bb5b9348a9ba6cad2e8aed26bfd10e3a3 (patch)
treecceb02d34be8c7f835ac3479456855d35e9e6e73 /libltdl/Makefile.am
parentc91afab6c988371f877216e5687f3a4c7f8ad13f (diff)
Integrate libtool/libltdl with the plugin code. Add libtool and libltdl
to the distribution. svn path=/trunk/; revision=1379
Diffstat (limited to 'libltdl/Makefile.am')
-rw-r--r--libltdl/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/libltdl/Makefile.am b/libltdl/Makefile.am
new file mode 100644
index 0000000000..a1df9fc37b
--- /dev/null
+++ b/libltdl/Makefile.am
@@ -0,0 +1,44 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = no-dependencies foreign
+
+if INSTALL_LTDL
+include_HEADERS = ltdl.h
+lib_LTLIBRARIES = libltdl.la
+else
+noinst_HEADERS = ltdl.h
+endif
+
+if CONVENIENCE_LTDL
+noinst_LTLIBRARIES = libltdlc.la
+endif
+
+libltdl_la_SOURCES = ltdl.c
+libltdl_la_LDFLAGS = -version-info 1:2:1
+libltdl_la_LIBADD = $(LIBADD_DL)
+
+libltdlc_la_SOURCES = ltdl.c
+libltdlc_la_LIBADD = $(LIBADD_DL)
+
+## Because we do not have automatic dependency tracking:
+ltdl.lo: ltdl.h config.h
+
+$(OBJECTS): libtool
+libtool: $(LIBTOOL_DEPS)
+ $(SHELL) ./config.status --recheck
+
+## This allows us to install libltdl without using ln and without creating
+## a world writeable directory.
+## FIXME: Remove this rule once automake can do this properly by itself.
+local-install-files: $(DISTFILES)
+ -rm -rf $(DESTDIR)$(datadir)/libtool/libltdl
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/libtool/libltdl
+ @for file in $(DISTFILES); do \
+ d=$(srcdir); \
+ if test -d $$d/$$file; then \
+ cp -r $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file; \
+ else \
+ test -f $(DESTDIR)$(datadir)/libtool/libltdl/$$file \
+ || cp $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file || :; \
+ fi; \
+ done