aboutsummaryrefslogtreecommitdiffstats
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorJakub Zawadzki <darkjames-ws@darkjames.pl>2011-04-26 10:10:22 +0000
committerJakub Zawadzki <darkjames-ws@darkjames.pl>2011-04-26 10:10:22 +0000
commit22b920d4617928c182d29fbba0a05dc879cca2fb (patch)
treeb5fa22fb24e6d012712a803eca38fef81e3acdf2 /gtk/Makefile.am
parentc833b47b6c549505e125fd5cbf206e4a95f831d3 (diff)
- Synchronize gtk/Makefile.am checkapi with gtk/Makefile.nmake
- fix: Found deprecated-gtk APIs in packet_win.c: gtk_entry_new_with_max_length svn path=/trunk/; revision=36867
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 18d2a0dcd1..5de8a4fd66 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -70,8 +70,16 @@ if HAVE_DOXYGEN
$(DOXYGEN) doxygen.cfg
endif # HAVE_DOXYGEN
-checkapi:
- $(PERL) ../tools/checkAPIs.pl \
+checkapi: checkapi-base checkapi-todo
+
+checkapi-base:
+ $(PERL) ../tools/checkAPIs.pl -g deprecated-gtk \
+ $(WIRESHARK_GTK_SRC) \
+ $(WIRESHARK_TAP_SRC) \
+ capture_if_details_dlg_win32.c
+
+checkapi-todo:
+ $(PERL) ../tools/checkAPIs.pl -M -g deprecated-gtk-todo \
$(WIRESHARK_GTK_SRC) \
$(WIRESHARK_TAP_SRC) \
capture_if_details_dlg_win32.c