aboutsummaryrefslogtreecommitdiffstats
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorgerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2009-11-10 18:02:05 +0000
committergerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2009-11-10 18:02:05 +0000
commit2ff7963ce3e9211d380310ec022d43babdf9b404 (patch)
tree0c4516a5389ae773788b20ac3220ed2318073b60 /gtk/Makefile.am
parented64f4829b309ac7fda623f6fcca36aa1b144d6e (diff)
Move the contents of image/expert_*.h to gtk/expert_indicators.h. Add
pixbuf versions of the wired, wireless, and bluetooth interface icons to gtk/network_icons.h. In the interface list use the new icons in all their alpha-channel-infested glory. Add Makefile targets for rebuilding the pixbuf files. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@30922 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 29b5848cf4..eb8ee9714d 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -65,3 +65,17 @@ checkapi:
capture_if_details_dlg_win32.c \
file_dlg_win32.c \
print_win32.c
+
+expert_indicators.h:
+ echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+ echo >> $@
+ for elevel in chat error none note warn ; do \
+ gdk-pixbuf-csource --raw --name=expert_$${elevel}_pb_data ../image/expert_$${elevel}.png >> $@ ;\
+ done
+
+network_icons.h:
+ echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+ echo >> $@
+ for icon in bluetooth wired wireless ; do \
+ gdk-pixbuf-csource --raw --name=network_$${icon}_pb_data ../image/toolbar/network_$${icon}_16.png >> $@ ;\
+ done