aboutsummaryrefslogtreecommitdiffstats
path: root/gtk/CMakeLists.txt
diff options
context:
space:
mode:
authorjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2011-07-28 14:21:29 +0000
committerjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2011-07-28 14:21:29 +0000
commitc96dd8eb2e13197be1ffe2a3a7d75d9a1868c154 (patch)
treeaaba54cdaa20879b1b9417c371819921d9142e41 /gtk/CMakeLists.txt
parent4ab5d064ff8c50a4f2dace7e00056db896737102 (diff)
- Always build with GSEAL_ENABLE
- Enable the extra warnings only when building with GTK2 (but not GTK3 directly). git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@38239 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'gtk/CMakeLists.txt')
-rw-r--r--gtk/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/gtk/CMakeLists.txt b/gtk/CMakeLists.txt
index 501cc252ac..dffc418bd5 100644
--- a/gtk/CMakeLists.txt
+++ b/gtk/CMakeLists.txt
@@ -231,6 +231,7 @@ add_definitions(
# struct fields so that you can go through them one by one and replace
# them with a call to an accessor function instead.
+ # Is enabled automatically when not building with GTK3 (see below).
# -DGSEAL_ENABLE
# To verify that your program does not use any deprecated symbols,
@@ -245,9 +246,19 @@ add_definitions(
if (UI_MANAGER)
add_definitions(
-DMAIN_MENU_USE_UIMANAGER=1
- -DGTK_DISABLE_DEPRECATED
)
+ if (NOT ENABLE_GTK3)
+ add_definitions(
+ -DGTK_DISABLE_DEPRECATED
+ )
+ endif()
endif()
+if (NOT ENABLE_GTK3)
+ add_definitions(
+ -DGSEAL_ENABLE
+ )
+endif()
+
if (WANT_PACKET_EDITOR)
add_definitions(
-DWANT_PACKET_EDITOR=1