aboutsummaryrefslogtreecommitdiffstats
path: root/extcap/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2016-02-14 17:00:38 -0800
committerGuy Harris <guy@alum.mit.edu>2016-02-15 08:31:06 +0000
commit58d00bad1a2c4298bd58013e4808899feb657422 (patch)
treec609d6f4b56c9f99432f4da736797af94161952c /extcap/Makefile.am
parent21ab9b2cbefeb73cdc605a90e8980240452567c0 (diff)
Build the extcap programs in the extcap directory.
That lets the version of Wireshark built with autotools find the extcap programs. Don't install the extcap programs under ${datadir} - that puts it under a share directory, and share directories are for platform-independent files, which executable images aren't (they're instruction-set dependent, hence platform-dependent). Change-Id: I992eeb984bdbe6b3476777f7114628c83df6080f Reviewed-on: https://code.wireshark.org/review/13943 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'extcap/Makefile.am')
-rw-r--r--extcap/Makefile.am74
1 files changed, 74 insertions, 0 deletions
diff --git a/extcap/Makefile.am b/extcap/Makefile.am
new file mode 100644
index 0000000000..08ea26e641
--- /dev/null
+++ b/extcap/Makefile.am
@@ -0,0 +1,74 @@
+# Makefile.am
+# Automake file for extcap tools
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+include ../Makefile.am.inc
+
+ACLOCAL_AMFLAGS = `../aclocal-flags`
+
+AM_CPPFLAGS += -I$(top_srcdir)/wiretap
+
+extcap_PROGRAMS = \
+ @androiddump_bin@ \
+ @randpktdump_bin@ \
+ @sshdump_bin@
+
+EXTRA_PROGRAMS = androiddump randpktdump sshdump
+
+if ENABLE_STATIC
+androiddump_LDFLAGS = -Wl,-static -all-static
+else
+androiddump_LDFLAGS = -export-dynamic
+endif
+
+# Libraries and plugin flags with which to link androiddump.
+androiddump_LDADD = \
+ ../wiretap/libwiretap.la \
+ ../wsutil/libwsutil.la \
+ @GLIB_LIBS@ \
+ @SOCKET_LIBS@
+
+if ENABLE_STATIC
+ randpktdump_LDFLAGS = -Wl,-static -all-static
+else
+ randpktdump_LDFLAGS = -export-dynamic
+endif
+
+# Libraries and plugin flags with which to link randpktdump.
+randpktdump_LDADD = \
+ ../randpkt_core/librandpkt_core.a \
+ ../wiretap/libwiretap.la \
+ ../wsutil/libwsutil.la \
+ @GLIB_LIBS@ \
+ @SOCKET_LIBS@
+
+if ENABLE_STATIC
+ sshdump_LDFLAGS = -Wl,-static -all-static
+else
+ sshdump_LDFLAGS = -export-dynamic
+endif
+
+# Libraries and plugin flags with which to link sshdump.
+sshdump_LDADD = \
+ ../wiretap/libwiretap.la \
+ ../wsutil/libwsutil.la \
+ @GLIB_LIBS@ \
+ @LIBSSH_LIBS@ \
+ @SOCKET_LIBS@