aboutsummaryrefslogtreecommitdiffstats
path: root/extcap/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-10-09 08:44:54 -0700
committerAnders Broman <a.broman58@gmail.com>2018-10-12 19:01:49 +0000
commitaba59e5973af5e8b2e0705bba3c8f2d47791261b (patch)
tree78f7620a15e3ffd76829cd0de76e925e34b0e15e /extcap/CMakeLists.txt
parent0efb1c6f6bf8d9f116dc5fb56eb0f9866bc575fc (diff)
Win32: Make extcap utilities console applications.
Switch from using WinMain in extcap to wmain. Change-Id: I54fafad598f5ff74fe84a3ce3e993ac5a31188f7 Reviewed-on: https://code.wireshark.org/review/30094 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'extcap/CMakeLists.txt')
-rw-r--r--extcap/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/extcap/CMakeLists.txt b/extcap/CMakeLists.txt
index de90d1d6d5..3035b53206 100644
--- a/extcap/CMakeLists.txt
+++ b/extcap/CMakeLists.txt
@@ -96,7 +96,7 @@ if(BUILD_androiddump)
)
set_executable_resources(androiddump "Androiddump")
- add_executable(androiddump WIN32 ${androiddump_FILES})
+ add_executable(androiddump ${androiddump_FILES})
# XXX Shouldn't we add wsutil to androiddump_LIBS instead?
set_extcap_executable_properties(androiddump)
target_link_libraries(androiddump ${androiddump_LIBS})
@@ -118,7 +118,7 @@ if(BUILD_sshdump AND LIBSSH_FOUND)
)
set_executable_resources(sshdump "Sshdump")
- add_executable(sshdump WIN32 ${sshdump_FILES})
+ add_executable(sshdump ${sshdump_FILES})
set_extcap_executable_properties(sshdump)
target_link_libraries(sshdump ${sshdump_LIBS})
target_include_directories(sshdump PUBLIC ${LIBSSH_INCLUDE_DIR})
@@ -143,7 +143,7 @@ if(BUILD_ciscodump AND LIBSSH_FOUND)
)
set_executable_resources(ciscodump "Ciscodump")
- add_executable(ciscodump WIN32 ${ciscodump_FILES})
+ add_executable(ciscodump ${ciscodump_FILES})
set_extcap_executable_properties(ciscodump)
target_link_libraries(ciscodump ${ciscodump_LIBS})
target_include_directories(ciscodump PUBLIC ${LIBSSH_INCLUDE_DIR})
@@ -167,7 +167,7 @@ if(BUILD_dpauxmon AND HAVE_LIBNL3)
)
set_executable_resources(dpauxmon "dpauxmon")
- add_executable(dpauxmon WIN32 ${dpauxmon_FILES})
+ add_executable(dpauxmon ${dpauxmon_FILES})
set_extcap_executable_properties(dpauxmon)
target_link_libraries(dpauxmon ${dpauxmon_LIBS})
target_include_directories(dpauxmon PUBLIC ${NL_INCLUDE_DIR})
@@ -190,7 +190,7 @@ if(BUILD_udpdump)
)
set_executable_resources(udpdump "udpdump")
- add_executable(udpdump WIN32 ${udpdump_FILES})
+ add_executable(udpdump ${udpdump_FILES})
set_extcap_executable_properties(udpdump)
target_link_libraries(udpdump ${udpdump_LIBS})
install(TARGETS udpdump RUNTIME DESTINATION ${EXTCAP_INSTALL_LIBDIR})
@@ -212,7 +212,7 @@ if(BUILD_randpktdump)
)
set_executable_resources(randpktdump "randpktdump")
- add_executable(randpktdump WIN32 ${randpktdump_FILES})
+ add_executable(randpktdump ${randpktdump_FILES})
# XXX Shouldn't we add wsutil to randpktdump_LIBS instead?
set_extcap_executable_properties(randpktdump)
target_link_libraries(randpktdump ${randpktdump_LIBS})
@@ -237,7 +237,7 @@ if(BUILD_sdjournal AND SYSTEMD_FOUND)
)
set_executable_resources(sdjournal "sdjournal")
- add_executable(sdjournal WIN32 ${sdjournal_FILES})
+ add_executable(sdjournal ${sdjournal_FILES})
set_extcap_executable_properties(sdjournal)
target_link_libraries(sdjournal ${sdjournal_LIBS})
install(TARGETS sdjournal RUNTIME DESTINATION ${EXTCAP_INSTALL_LIBDIR})