aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorHadriel Kaplan <hadrielk@yahoo.com>2014-03-26 02:24:51 -0400
committerAnders Broman <a.broman58@gmail.com>2014-03-26 07:37:34 +0000
commit8c2bb805742c918b933923947a533d098774da75 (patch)
treeb3859068c4fdd09bd26ab01168835a042715644b /epan/wslua/Makefile.am
parentda1af6e549856c8e213dadc1ec37a41a50246e1d (diff)
Add various functions for Lua directory handling and path info
This adds new functions to get plugins path info, find out if a directory exists, make a new one, remove one, etc. It also creates a file environment for user-supplied Lua scripts, to prevent global variable contamination as well as supply the script-specific file name. Some other minor cleanup was done as I found them. A new testsuite was added to test the existing and new directory functions. Change-Id: I19bd587b5e8a73d89b8521af73670e023314fb33 Reviewed-on: https://code.wireshark.org/review/832 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index 96c455e2dc..27dd367e6f 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -41,6 +41,7 @@ wslua_modules = \
$(srcdir)/wslua_pinfo.c \
$(srcdir)/wslua_listener.c \
$(srcdir)/wslua_gui.c \
+ $(srcdir)/wslua_dir.c \
$(srcdir)/wslua_util.c \
$(srcdir)/wslua_field.c \
$(srcdir)/wslua_file.c \
@@ -144,4 +145,5 @@ checkapi:
wslua_tree.c \
wslua_tree.c \
wslua_tvb.c \
+ wslua_dir.c \
wslua_util.c