aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2014-08-11 16:41:38 -0400
committerAnders Broman <a.broman58@gmail.com>2014-08-12 04:14:12 +0000
commit4fd9809a7887ef8bbb2f850e22f5766b4cb223e3 (patch)
tree7557755279bfa0e3b1246b411638aaed2aed1c0d /epan/wslua/Makefile.am
parent50c7d8ef96abb57a9e90ed18174a51e81e7b1bd5 (diff)
Fix generation of wslua taps in out-of-source-tree builds when the source tree
is a source tarball (rather than git): Don't put the $(srcdir) path (from when the source tarball was made) into the C file: that file isn't regenerated when ./configure is run. (This is a correction to 0996730b91fddbf8aa7c61730a50da28ea1ab6a0). Also change a few dependency paths so they'll work in out-of-source-tree builds. Change-Id: I416f2d3611fb61659b9a7f7285e5f54a354fbe7d Reviewed-on: https://code.wireshark.org/review/3554 Petri-Dish: Jeff Morriss <jeff.morriss.ws@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Evan Huus <eapache@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index 0c2b052848..26f43e1b35 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -98,11 +98,11 @@ EXTRA_DIST = \
CMakeLists.txt
taps_used = \
- ../dissectors/packet-http.h \
- ../dissectors/packet-ip.h \
- ../dissectors/packet-udp.h \
- ../dissectors/packet-h225.h \
- ../dissectors/packet-ieee80211.h
+ $(top_srcdir)/epan/dissectors/packet-http.h \
+ $(top_srcdir)/epan/dissectors/packet-ip.h \
+ $(top_srcdir)/epan/dissectors/packet-udp.h \
+ $(top_srcdir)/epan/dissectors/packet-h225.h \
+ $(top_srcdir)/epan/dissectors/packet-ieee80211.h
taps_wslua.c: make-taps.pl $(srcdir)/taps $(taps_used)
$(PERL) $(srcdir)/make-taps.pl $(srcdir)/taps taps_wslua.c taps.txt $(srcdir)
@@ -116,7 +116,7 @@ register_wslua.c: declare_wslua.h
declare_wslua.h: make-reg.pl $(wslua_modules) taps_wslua.c
$(PERL) $(srcdir)/make-reg.pl $(wslua_modules);
-init.lua: template-init.lua make-init-lua.pl ../ftypes/ftypes.h ../../wiretap/wtap.h ../proto.h ../stat_groups.h
+init.lua: template-init.lua make-init-lua.pl $(top_srcdir)/epan/ftypes/ftypes.h $(top_srcdir)/wiretap/wtap.h $(top_srcdir)/epan/proto.h $(top_srcdir)/epan/stat_groups.h
$(PERL) $(srcdir)/make-init-lua.pl $(top_srcdir) $(srcdir)/template-init.lua > init.lua
checkapi: