aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorLuis Ontanon <luis.ontanon@gmail.com>2006-10-17 18:20:44 +0000
committerLuis Ontanon <luis.ontanon@gmail.com>2006-10-17 18:20:44 +0000
commitb8ef88a6e224192c3d19310e859d655377c6ae1c (patch)
tree1ee746243482ff3fe184e88beb6b55dbdf219cbe /epan/wslua/Makefile.am
parent482ded17c639d2722a9d6dbaba622cde358eae3e (diff)
Several changes:
- do not #include a c code file in wslua_register.c compile a separate boject - add the console and evaluate windows - add some useful vars to the lua environment - some cleanup - add the dtd generator code (currently disabled) svn path=/trunk/; revision=19579
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index ab002ef2d5..3daff8718a 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -38,6 +38,7 @@ wslua_modules = \
libwslua_la_SOURCES = \
$(wslua_modules) \
+ taps_wslua.c \
register_wslua.c \
init_wslua.c \
wslua.h
@@ -45,11 +46,14 @@ libwslua_la_SOURCES = \
libwslua_la_LIBADD = @LUA_LIBS@
BUILT_SOURCES = \
- taps.c-inc \
+ taps_wslua.c \
register_wslua.c \
declare_wslua.h
-pkgdata_DATA = init.lua
+pkgdata_DATA = \
+ init.lua \
+ console.lua \
+ dtd_gen.lua
CLEANFILES = \
*~
@@ -86,10 +90,10 @@ taps_used = \
taps: $(taps_used)
touch taps
-taps.c-inc: make-taps.pl taps
- $(PERL) $(srcdir)/make-taps.pl taps taps.c-inc taps.txt
+taps_wslua.c: make-taps.pl taps
+ $(PERL) $(srcdir)/make-taps.pl taps taps_wslua.c taps.txt
-taps.txt: taps.c-inc
+taps.txt: taps_wslua.c
wslua.h: declare_wslua.h