aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorLuis Ontanon <luis.ontanon@gmail.com>2006-10-03 14:27:45 +0000
committerLuis Ontanon <luis.ontanon@gmail.com>2006-10-03 14:27:45 +0000
commite23201c62a65bbac178b27ffb4d067c3de109301 (patch)
tree12ce7c6d55d40c055745c1cf6ca1933883d39f71 /epan/wslua/Makefile.am
parent3474ea868c8822f54eecd736a8abadbf2203e60d (diff)
- Make sure that the registration files are created whenever there's a change
- get rid of 5.0.2 stuff - add the apply_filter() API svn path=/trunk/; revision=19406
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am43
1 files changed, 14 insertions, 29 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index 75e72bbccd..cea8f43523 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -38,6 +38,7 @@ wslua_modules = \
libwslua_la_SOURCES = \
$(wslua_modules) \
+ register_wslua.c \
init_wslua.c \
wslua.h
@@ -45,7 +46,8 @@ libwslua_la_LIBADD = @LUA_LIBS@
BUILT_SOURCES = \
taps.c-inc \
- wslua_register.h
+ register_wslua.c \
+ declare_wslua.h
pkgdata_DATA = init.lua
@@ -63,7 +65,8 @@ MAINTAINERCLEANFILES = \
init.lua
EXTRA_DIST = \
- wslua_register.h \
+ declare_wslua.h \
+ register_wslua.c \
taps \
make-reg.pl \
make-doc.pl \
@@ -86,33 +89,15 @@ taps.c-inc: make-taps.pl taps
taps.txt: taps.c-inc
-wslua.h: wslua_register.h
-
-# do not do not unnecessarilly modify the old file in order avoid recompiling every module every time
-wslua_register.h: make-reg.pl $(lua_modules) taps.c-inc
- $(PERL) $(srcdir)/make-reg.pl \
- wslua_tvb.c \
- wslua_proto.c \
- wslua_tree.c \
- wslua_pinfo.c \
- wslua_listener.c \
- wslua_gui.c \
- wslua_util.c \
- wslua_field.c \
- wslua_dumper.c > wslua_register.h.new ;\
- if diff wslua_register.h.new wslua_register.h >/dev/null; then rm wslua_register.h.new; else mv wslua_register.h.new wslua_register.h; fi
-
-doc: make-doc.pl $(lua_modules)
- $(PERL) $(srcdir)/make-doc.pl \
- wslua_tvb.c \
- wslua_proto.c \
- wslua_tree.c \
- wslua_pinfo.c \
- wslua_listener.c \
- wslua_gui.c \
- wslua_util.c \
- wslua_field.c \
- wslua_dumper.c
+wslua.h: declare_wslua.h
+
+register_wslua.c: declare_wslua.h
+
+declare_wslua.h: make-reg.pl $(wslua_modules) taps.c-inc
+ $(PERL) $(srcdir)/make-reg.pl $(wslua_modules);
+
+doc: make-doc.pl $(wslua_modules)
+ $(PERL) $(srcdir)/make-doc.pl $(wslua_modules)
dummy:
touch dummy