aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2014-08-01 16:14:23 -0400
committerEvan Huus <eapache@gmail.com>2014-08-02 01:00:05 +0000
commit6b11cd97f2153bb015ade6efd05929999de85457 (patch)
tree361e91fabf668189dba6ecb8b8653e4b9313d76f /epan/wslua/Makefile.am
parent69d0788875b81b2cdd0c751f00eb5b20944ffe15 (diff)
Make Lua taps work in out-of-source-tree builds.
make-taps.pl needs to know where to find the source files otherwise none of the tap data gets built correctly. This makes the wslua test suite run in out-of-source-tree builds too. Change-Id: I059474d90d59e87bd57dba18530a66a927a014cf Reviewed-on: https://code.wireshark.org/review/3337 Reviewed-by: Evan Huus <eapache@gmail.com>
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index 85203ced2d..e57f280078 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -3,17 +3,17 @@
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
# Copyright 1998 Gerald Combs
-#
+#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
# of the License, or (at your option) any later version.
-#
+#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -108,7 +108,7 @@ taps: $(taps_used)
touch taps
taps_wslua.c: make-taps.pl taps
- $(PERL) $(srcdir)/make-taps.pl taps taps_wslua.c taps.txt
+ $(PERL) $(srcdir)/make-taps.pl $(srcdir)/taps taps_wslua.c taps.txt $(srcdir)
taps.txt: taps_wslua.c