aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2007-08-02 07:54:03 +0000
committerGuy Harris <guy@alum.mit.edu>2007-08-02 07:54:03 +0000
commit4f00d5fcc1fa792e573160e728c22a7484f80f32 (patch)
tree614672db96067c5d5571960d0775d82d8b41aaa2 /epan/wslua/Makefile.am
parent15626ed97654618320ce31f9b9f17f6c0e15979d (diff)
Move the list of source files to a Makefile.common file.
Don't put $(srcdir)/ at the beginning of those file names - other Makefile.am files don't have it, and it appears to break "make distcheck", at least on my Mac OS X 10.4 machine. svn path=/trunk/; revision=22439
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am16
1 files changed, 3 insertions, 13 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index 8784ffa09c..f40f1f7ff5 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -18,7 +18,7 @@
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
#
if HAVE_WARNINGS_AS_ERRORS
@@ -29,19 +29,8 @@ INCLUDES = -I$(top_srcdir) @LUA_INCLUDES@
noinst_LTLIBRARIES = libwslua.la
-wslua_modules = \
- $(srcdir)/wslua_tvb.c \
- $(srcdir)/wslua_proto.c \
- $(srcdir)/wslua_tree.c \
- $(srcdir)/wslua_pinfo.c \
- $(srcdir)/wslua_listener.c \
- $(srcdir)/wslua_gui.c \
- $(srcdir)/wslua_util.c \
- $(srcdir)/wslua_field.c \
- $(srcdir)/wslua_dumper.c
-
libwslua_la_SOURCES = \
- $(wslua_modules) \
+ $(MODULES) \
taps_wslua.c \
register_wslua.c \
init_wslua.c \
@@ -81,6 +70,7 @@ EXTRA_DIST = \
template-init.lua \
make-init-lua.pl \
make-taps.pl \
+ Makefile.common \
Makefile.nmake
taps_used = \