aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorHadriel Kaplan <hadrielk@yahoo.com>2014-02-02 22:49:30 -0500
committerEvan Huus <eapache@gmail.com>2014-02-04 00:37:46 +0000
commit2e7f771a182df815e8c3d38986a1df0c77d7e4aa (patch)
tree7e0fb8f65c75c19788fb3af273ec9228e696206e /epan/wslua/Makefile.am
parentcaed2818c94312d5df5d66fa20c6bba28fd49499 (diff)
Adds support for Lua Int64 and UInt64 operators, functions, and general
usefulness, working around bug #9162 until Lua 5.3 is released. The existing Int64 and UInt64 classes provide virtually no usefullness, other than for creating a string of their value. While one could then write Lua code to convert the string to Lua numbers and such, ultimately Lua has no native 64-bit integer support, making such a task difficult to handle in Lua. This change adds a host of functions and operators to the existing Int64 (gint64) and UInt64 (guint64) classes, to enable true 64-bit integer support on par with native Lua numbers. A test script is also provided, which tests the functions/operators. Change-Id: I4c5f8f5219b9a88198902283bd32ddf24c346bbe Reviewed-on: https://code.wireshark.org/review/83 Tested-by: Evan Huus <eapache@gmail.com> Reviewed-by: Evan Huus <eapache@gmail.com>
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index 88f063c84d..e5789c1d7d 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -33,6 +33,7 @@ wslua_modules = \
$(srcdir)/lua_bitop.c \
$(srcdir)/wslua_tvb.c \
$(srcdir)/wslua_proto.c \
+ $(srcdir)/wslua_int64.c \
$(srcdir)/wslua_tree.c \
$(srcdir)/wslua_pinfo.c \
$(srcdir)/wslua_listener.c \
@@ -125,6 +126,7 @@ checkapi:
wslua_dumper.c \
wslua_field.c \
wslua_gui.c \
+ wslua_int64.c \
wslua_pinfo.c \
wslua_proto.c \
wslua_listener.c \