aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2014-08-01 16:14:23 -0400
committerEvan Huus <eapache@gmail.com>2014-08-03 17:26:25 +0000
commit0996730b91fddbf8aa7c61730a50da28ea1ab6a0 (patch)
treeab8cb88d75c56a1d5aab68e251b5afc943a10228 /epan/wslua/Makefile.am
parentd34d09ebe4c983ca4174a56aae69a6a6b699c1c9 (diff)
Make Lua taps work in out-of-source-tree builds.
make-taps.pl needs to know where to find the source files in order to build the taps. This makes the wslua test suite run in autofoo out-of-source-tree builds too. To make it work with cmake builds requires putting all the epan/wslua/ output (or at least init.lua) in epan/wslua/ instead of epan/. Change-Id: I1b3c517f08d3c752ee03cb89482ee4951ceb5bf3 Reviewed-on: https://code.wireshark.org/review/3348 Petri-Dish: Evan Huus <eapache@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Evan Huus <eapache@gmail.com>
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index 85203ced2d..0c2b052848 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -3,17 +3,17 @@
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
# Copyright 1998 Gerald Combs
-#
+#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
# of the License, or (at your option) any later version.
-#
+#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -104,11 +104,8 @@ taps_used = \
../dissectors/packet-h225.h \
../dissectors/packet-ieee80211.h
-taps: $(taps_used)
- touch taps
-
-taps_wslua.c: make-taps.pl taps
- $(PERL) $(srcdir)/make-taps.pl taps taps_wslua.c taps.txt
+taps_wslua.c: make-taps.pl $(srcdir)/taps $(taps_used)
+ $(PERL) $(srcdir)/make-taps.pl $(srcdir)/taps taps_wslua.c taps.txt $(srcdir)
taps.txt: taps_wslua.c
@@ -119,9 +116,6 @@ register_wslua.c: declare_wslua.h
declare_wslua.h: make-reg.pl $(wslua_modules) taps_wslua.c
$(PERL) $(srcdir)/make-reg.pl $(wslua_modules);
-dummy:
- touch dummy
-
init.lua: template-init.lua make-init-lua.pl ../ftypes/ftypes.h ../../wiretap/wtap.h ../proto.h ../stat_groups.h
$(PERL) $(srcdir)/make-init-lua.pl $(top_srcdir) $(srcdir)/template-init.lua > init.lua