aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2015-01-20 20:41:49 -0500
committerJeff Morriss <jeff.morriss.ws@gmail.com>2015-01-22 02:12:46 +0000
commit042623617bf261c5b8409b1efe5bc798ff54312d (patch)
tree40e708dd64d528aae24d884d8ceb4583578a7349 /epan/wslua/Makefile.am
parentd93a90b445d1e5821eec32e1e2327d5836188fff (diff)
Get us building with the subdir-objects automake option.
subdir-objects will be enabled unconditionally in automake-2.0 and automake-1.14 gives us warnings about the upcoming change. Rework I1b3c517f08d3c752ee03cb89482ee4951ceb5bf3 (and I416f2d3611fb61659b9a7f7285e5f54a354fbe7d) to give wslua/make-reg.pl the directory of the source files rather than the full path to each. In echld don't use sources in the top-level directory in libechld: it breaks distclean with subdir-objects turned on. Bug: 10648 Change-Id: I404b074f1558376064c35d8fc96aea7e3d042a76 Reviewed-on: https://code.wireshark.org/review/6697 Petri-Dish: Jeff Morriss <jeff.morriss.ws@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am38
1 files changed, 19 insertions, 19 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index 26f43e1b35..6d2caa47dd 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -28,24 +28,24 @@ AM_CPPFLAGS = -I$(top_srcdir) @LUA_INCLUDES@
noinst_LTLIBRARIES = libwslua.la
wslua_modules = \
- $(srcdir)/lua_bitop.c \
- $(srcdir)/lrexlib.c \
- $(srcdir)/lrexlib_glib.c \
- $(srcdir)/lrexlib_glib_f.c \
- $(srcdir)/wslua_tvb.c \
- $(srcdir)/wslua_proto.c \
- $(srcdir)/wslua_int64.c \
- $(srcdir)/wslua_tree.c \
- $(srcdir)/wslua_pinfo.c \
- $(srcdir)/wslua_listener.c \
- $(srcdir)/wslua_gui.c \
- $(srcdir)/wslua_dir.c \
- $(srcdir)/wslua_util.c \
- $(srcdir)/wslua_field.c \
- $(srcdir)/wslua_file.c \
- $(srcdir)/wslua_struct.c \
- $(srcdir)/wslua_dumper.c \
- $(srcdir)/wslua_internals.c
+ lua_bitop.c \
+ lrexlib.c \
+ lrexlib_glib.c \
+ lrexlib_glib_f.c \
+ wslua_tvb.c \
+ wslua_proto.c \
+ wslua_int64.c \
+ wslua_tree.c \
+ wslua_pinfo.c \
+ wslua_listener.c \
+ wslua_gui.c \
+ wslua_dir.c \
+ wslua_util.c \
+ wslua_field.c \
+ wslua_file.c \
+ wslua_struct.c \
+ wslua_dumper.c \
+ wslua_internals.c
libwslua_la_SOURCES = \
$(wslua_modules) \
@@ -114,7 +114,7 @@ wslua.h: declare_wslua.h
register_wslua.c: declare_wslua.h
declare_wslua.h: make-reg.pl $(wslua_modules) taps_wslua.c
- $(PERL) $(srcdir)/make-reg.pl $(wslua_modules);
+ $(PERL) $(srcdir)/make-reg.pl -d $(srcdir) $(wslua_modules)
init.lua: template-init.lua make-init-lua.pl $(top_srcdir)/epan/ftypes/ftypes.h $(top_srcdir)/wiretap/wtap.h $(top_srcdir)/epan/proto.h $(top_srcdir)/epan/stat_groups.h
$(PERL) $(srcdir)/make-init-lua.pl $(top_srcdir) $(srcdir)/template-init.lua > init.lua