aboutsummaryrefslogtreecommitdiffstats
path: root/epan/wmem/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-04-07 15:31:21 -0700
committerMichael Mann <mmann78@netscape.net>2016-07-30 16:29:36 +0000
commit183d7f3b78de30581390244a72c6ab328e6338f0 (patch)
tree9071a421aa28bfe201a06718b855cd2659a6398b /epan/wmem/CMakeLists.txt
parent852a56139e6c0c3ea4b844c6837cb13db339e1b3 (diff)
Add string function times to wmem_test.
The system, GLib, and wmem string functions can perform differently, particularly on Windows. Start adding performance tests to wmem_test so that we can see the differences. With this change applied "wmem_test --verbose" prints out the following on a Windows 7 x64 VM here. wmem_test is linked against GLib 2.4.20. (MINPERF:g_printf_string_upper_bound (via g_snprintf) 1 string: u 327.602 ms s 0 .000 ms) (MINPERF:g_printf_string_upper_bound (via g_snprintf) 5 strings: u 1419.609 ms s 0.000 ms) (MINPERF:g_printf_string_upper_bound (via g_snprintf) mixed args: u 1606.810 ms s 0.000 ms) (MINPERF:_snprintf_s upper bound 1 string: u 124.801 ms s 0.000 ms) (MINPERF:_snprintf_s upper bound 5 strings: u 140.401 ms s 0.000 ms) (MINPERF:_snprintf_s upper bound mixed args: u 124.801 ms s 0.000 ms) (MINPERF:g_strdup_printf 2 strings: u 702.005 ms s 0.156 ms) (MINPERF:g_strconcat 2 strings: u 78.000 ms s 0.000 ms) (MINPERF:g_strdup_printf 5 strings: u 1419.609 ms s 0.156 ms) (MINPERF:g_strconcat 5 strings: u 93.601 ms s 0.156 ms) (MINPERF:wmem_strdup_printf 2 strings: u 343.202 ms s 0.312 ms) (MINPERF:wmem_strconcat 2 strings: u 93.601 ms s 0.468 ms) (MINPERF:wmem_strdup_printf 5 strings: u 327.602 ms s 8.268 ms) (MINPERF:wmem_strconcat 5 strings: u 62.400 ms s 3.432 ms) Change-Id: Id9b23918829db1719d141e7f830b9eba6245a25b Reviewed-on: https://code.wireshark.org/review/14857 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'epan/wmem/CMakeLists.txt')
-rw-r--r--epan/wmem/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/epan/wmem/CMakeLists.txt b/epan/wmem/CMakeLists.txt
index 65633484f8..524b8b4921 100644
--- a/epan/wmem/CMakeLists.txt
+++ b/epan/wmem/CMakeLists.txt
@@ -63,7 +63,7 @@ set_target_properties(wmem PROPERTIES
add_executable(wmem_test EXCLUDE_FROM_ALL wmem_test.c $<TARGET_OBJECTS:wmem>)
-target_link_libraries(wmem_test ${GLIB2_LIBRARIES})
+target_link_libraries(wmem_test ${GLIB2_LIBRARIES} wsutil)
set_target_properties(wmem_test PROPERTIES
FOLDER "Tests"