aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/asn1/CMakeLists.txt
diff options
context:
space:
mode:
authorChristophe GUERBER <christophe.guerber@gmail.com>2018-12-14 22:41:28 +0100
committerAnders Broman <a.broman58@gmail.com>2018-12-18 12:31:48 +0000
commitc7f7b60c6b4cf6a316de8ec84794a44c8ff43d16 (patch)
tree56677a500336cc264943314e1a2d8e1d45e27bfc /epan/dissectors/asn1/CMakeLists.txt
parentae83101dd5643c3852ca67ffb331cd8dbd20c727 (diff)
ITS facilities message dissector
Dissector for Intelligent Transport System facility messages: - Cooperative Awareness Message (CAM) - Decentralized Environmental Notification Message (DENM) - Infrastructure to Vehicle Information Message (IVIM) - MAP (topology) Extended Message (MAPEM) - Signal Phase And Timing Extended Message (SPATEM) - Signal Request Extended Message (SREM) - Signal request Status Extended Message (SSEM) - Electric Vehicle Charging Spot Notification (EVCSN) - Electric Vehicle - Recharging Spot Reservation (EVRSR) - Tyre Information System (TIS) and Tyre Pressure Gauge (TPG) interoperability Subdissectors: - ITS version if ever the ITS PDU header is changed - Version << 16 | MessageID to register new message dissectors - RegionId << 16 | type to register regional extensions AddGrpC regional additions already provided TAP: - its TAP with ItsPduHeader fields provided Bug: 15148 Change-Id: I4c71d4dfa1d5d63cb57f61a4e1436a60a3482205 Reviewed-on: https://code.wireshark.org/review/31049 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/dissectors/asn1/CMakeLists.txt')
-rw-r--r--epan/dissectors/asn1/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/asn1/CMakeLists.txt b/epan/dissectors/asn1/CMakeLists.txt
index c891dcc31c..05f6a362b0 100644
--- a/epan/dissectors/asn1/CMakeLists.txt
+++ b/epan/dissectors/asn1/CMakeLists.txt
@@ -58,6 +58,7 @@ set(ASN1_SRC_DIRS
ilp
inap
isdn-sup
+ its
kerberos
lcsap
ldap