aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/Makefile.am
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2006-04-19 09:52:23 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2006-04-19 09:52:23 +0000
commitde2b7a81688963d567f5373d8fe84383ba1cf446 (patch)
treecbf7a66fc2ed2628f4b122293c3b29030d3098e7 /epan/dissectors/Makefile.am
parentc43c9f0020cd02923233d33860f4d805009ba973 (diff)
Update comments.
Fix the Makefile.nmake files to pass the output type argument to make-reg-dotc or make-reg-dotc.py. Make tools/make-reg-dotc executable. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@17904 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'epan/dissectors/Makefile.am')
-rw-r--r--epan/dissectors/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/epan/dissectors/Makefile.am b/epan/dissectors/Makefile.am
index aeeed1dcb9..cbe866d647 100644
--- a/epan/dissectors/Makefile.am
+++ b/epan/dissectors/Makefile.am
@@ -73,6 +73,10 @@ x11-declarations.h x11-register-info.h: $(PROC_X11_FIELDS) $(X11_FIELDS)
# reason.
#
# Therefore, we have a script to generate the register.c file.
+# The shell script runs slowly, as multiple greps and seds are run
+# for each input file; this is especially slow on Windows. Therefore,
+# if Python is present (as indicated by PYTHON being defined), we run
+# a faster Python script to do that work instead.
#
# The first argument is the directory in which the source files live.
# The second argument is "dissectors", to indicate that we should build
@@ -88,7 +92,7 @@ register.c: $(plugin_src) $(DISSECTOR_SRC) $(top_srcdir)/tools/make-reg-dotc \
else \
echo Making register.c with shell script ; \
$(top_srcdir)/tools/make-reg-dotc $(srcdir) \
- $(plugin_src) dissectors $(DISSECTOR_SRC) ; \
+ dissectors $(plugin_src) $(DISSECTOR_SRC) ; \
fi
#