aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2006-04-20 02:21:28 +0000
committerGuy Harris <guy@alum.mit.edu>2006-04-20 02:21:28 +0000
commitfd1cec89175ac70bdac07e0de8087eca9bd49026 (patch)
treefceb11315955f31d51a8e2b2a8d67bb5bb1e04d7 /epan/dissectors/Makefile.am
parent4a67045746756d775deedbbc949fbf786c2c4c8f (diff)
Rename "make-reg-dotc" to "make-dissector-reg", and do the same for the
Python versions, as it no longer makes only "register.c", it can also make a "plugin.c" file for a plugin. When making "plugin.c", there's no need to include "register.h", as it's not defining any functions declared there. svn path=/trunk/; revision=17919
Diffstat (limited to 'epan/dissectors/Makefile.am')
-rw-r--r--epan/dissectors/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/epan/dissectors/Makefile.am b/epan/dissectors/Makefile.am
index cbe866d647..5847115d8c 100644
--- a/epan/dissectors/Makefile.am
+++ b/epan/dissectors/Makefile.am
@@ -83,15 +83,15 @@ x11-declarations.h x11-register-info.h: $(PROC_X11_FIELDS) $(X11_FIELDS)
# a register.c file for libethereal.
# All subsequent arguments are the files to scan.
#
-register.c: $(plugin_src) $(DISSECTOR_SRC) $(top_srcdir)/tools/make-reg-dotc \
- $(top_srcdir)/tools/make-reg-dotc.py
+register.c: $(plugin_src) $(DISSECTOR_SRC) $(top_srcdir)/tools/make-dissector-reg \
+ $(top_srcdir)/tools/make-dissector-reg.py
@if test -n $(PYTHON); then \
echo Making register.c with python ; \
- $(PYTHON) $(top_srcdir)/tools/make-reg-dotc.py $(srcdir) \
+ $(PYTHON) $(top_srcdir)/tools/make-dissector-reg.py $(srcdir) \
dissectors $(DISSECTOR_SRC) ; \
else \
echo Making register.c with shell script ; \
- $(top_srcdir)/tools/make-reg-dotc $(srcdir) \
+ $(top_srcdir)/tools/make-dissector-reg $(srcdir) \
dissectors $(plugin_src) $(DISSECTOR_SRC) ; \
fi