aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2006-04-17 00:41:54 +0000
committerGuy Harris <guy@alum.mit.edu>2006-04-17 00:41:54 +0000
commite7d75a821ded66cf485e2aa8822b5b487dc9cc6c (patch)
tree92e257dde7d4e54dde352060f4aa94f0f0d66d5e /epan/dissectors/Makefile.am
parent1c26abfe29a9d126f743ec37aaa75e0850528231 (diff)
Move "make-reg-dotc" and "make-reg-dotc.py" to the "tools" directory, so
that it can more easily be used when building plugins. svn path=/trunk/; revision=17881
Diffstat (limited to 'epan/dissectors/Makefile.am')
-rw-r--r--epan/dissectors/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/epan/dissectors/Makefile.am b/epan/dissectors/Makefile.am
index e54c624ee4..12f245178d 100644
--- a/epan/dissectors/Makefile.am
+++ b/epan/dissectors/Makefile.am
@@ -33,8 +33,6 @@ libdissectors_la_SOURCES = \
EXTRA_DIST = \
Makefile.common \
Makefile.nmake \
- make-reg-dotc \
- make-reg-dotc.py \
ncp2222.py \
packet-ncp2222.inc \
process-x11-fields.pl \
@@ -77,13 +75,14 @@ x11-declarations.h x11-register-info.h: $(PROC_X11_FIELDS) $(X11_FIELDS)
# The second argument is the directory in which the source files live.
# All subsequent arguments are the files to scan.
#
-register.c: $(plugin_src) $(DISSECTOR_SRC) $(srcdir)/make-reg-dotc $(srcdir)/make-reg-dotc.py
+register.c: $(plugin_src) $(DISSECTOR_SRC) $(top_srcdir)/tools/make-reg-dotc \
+ $(top_srcdir)/tools/make-reg-dotc.py
@if test -n $(PYTHON); then \
echo Making register.c with python ; \
- $(PYTHON) $(srcdir)/make-reg-dotc.py $(srcdir) $(DISSECTOR_SRC) ; \
+ $(PYTHON) $(top_srcdir)/tools/make-reg-dotc.py $(srcdir) $(DISSECTOR_SRC) ; \
else \
echo Making register.c with shell script ; \
- $(srcdir)/make-reg-dotc register.c $(srcdir) \
+ $(top_srcdir)/tools/make-reg-dotc register.c $(srcdir) \
$(plugin_src) $(DISSECTOR_SRC) ; \
fi