aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2009-09-11 01:57:59 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2009-09-11 01:57:59 +0000
commit961cd3c6ce821c21000d8009b562fc5fafbd0d7a (patch)
tree6af8c67fd36a2fc7d5574426952b6ee1ba8808c2 /epan/dissectors/Makefile.am
parentb75a84dd4fac59c1e7d40eb4a101841e0088d507 (diff)
From Peter Harris via https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=2981 :
This patch adds extension support to the X11 dissector. I've removed the perl script from the make file, since the new one depends on perl 5.10, xcbproto (at least git as of today), and mesa (at least the mesa/src/mesa/glapi directory). It seemed easier to just add the generated header files to svn directly. svn path=/trunk/; revision=29854
Diffstat (limited to 'epan/dissectors/Makefile.am')
-rw-r--r--epan/dissectors/Makefile.am13
1 files changed, 1 insertions, 12 deletions
diff --git a/epan/dissectors/Makefile.am b/epan/dissectors/Makefile.am
index 21862d5e7a..6729628942 100644
--- a/epan/dissectors/Makefile.am
+++ b/epan/dissectors/Makefile.am
@@ -48,23 +48,12 @@ EXTRA_DIST = \
Makefile.common \
Makefile.nmake \
ncp2222.py \
- packet-ncp2222.inc \
- process-x11-fields.pl \
- x11-fields
+ packet-ncp2222.inc
packet-ncp2222.c : $(srcdir)/ncp2222.py
$(PYTHON) $< -o $@
#
-# Build various header files for the X11 dissector.
-#
-PROC_X11_FIELDS = $(srcdir)/process-x11-fields.pl
-X11_FIELDS = $(srcdir)/x11-fields
-
-x11-declarations.h x11-register-info.h: $(PROC_X11_FIELDS) $(X11_FIELDS)
- $(PERL) $(PROC_X11_FIELDS) < $(X11_FIELDS)
-
-#
# Build register.c, which contains a function register_all_protocols()
# that calls the register routines for all protocols and a function
# register_all_protocol_handoffs() that calls the handoff registration