aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/Makefile.am
diff options
context:
space:
mode:
authorSebastien Tandel <sebastien@tandel.be>2007-04-03 20:22:32 +0000
committerSebastien Tandel <sebastien@tandel.be>2007-04-03 20:22:32 +0000
commitedfd0718817404f5e4b196f4db514d8ffb391469 (patch)
tree17ca791a20adae82b816bf623465fb77c324ed8f /epan/dissectors/Makefile.am
parent2e26bbeda380295c1e7dca0d64593757d960a8f3 (diff)
Creation of ALL_DISSECTORS_SRC including all dissectors sources
- used in Makefile.nmake instead of DISSECTOR_SRC - used for the target register.c svn path=/trunk/; revision=21327
Diffstat (limited to 'epan/dissectors/Makefile.am')
-rw-r--r--epan/dissectors/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/epan/dissectors/Makefile.am b/epan/dissectors/Makefile.am
index 972fc04ba9..cd7a2358e9 100644
--- a/epan/dissectors/Makefile.am
+++ b/epan/dissectors/Makefile.am
@@ -101,18 +101,16 @@ x11-declarations.h x11-register-info.h: $(PROC_X11_FIELDS) $(X11_FIELDS)
# a register.c file for libwireshark.
# All subsequent arguments are the files to scan.
#
-register.c: $(plugin_src) $(DISSECTOR_SRC) $(top_srcdir)/tools/make-dissector-reg \
+register.c: $(plugin_src) $(ALL_DISSECTORS_SRC) $(top_srcdir)/tools/make-dissector-reg \
$(top_srcdir)/tools/make-dissector-reg.py
@if test -n $(PYTHON); then \
echo Making register.c with python ; \
$(PYTHON) $(top_srcdir)/tools/make-dissector-reg.py $(srcdir) \
- dissectors $(DISSECTOR_SRC) $(CLEAN_DISSECTOR_SRC) \
- $(PIDL_DISSECTOR_SRC) $(ASN_DISSECTOR_SRC) ; \
+ dissectors $(ALL_DISSECTORS_SRC) ; \
else \
echo Making register.c with shell script ; \
$(top_srcdir)/tools/make-dissector-reg $(srcdir) \
- dissectors $(plugin_src) $(DISSECTOR_SRC) $(CLEAN_DISSECTOR_SRC) \
- $(PIDL_DISSECTOR_SRC) $(ASN_DISSECTOR_SRC) ; \
+ dissectors $(plugin_src) $(ALL_DISSECTORS_SRC) ; \
fi
#
# Currently register.c can be included in the distribution because