aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2018-07-31 21:57:42 -0700
committerGuy Harris <guy@alum.mit.edu>2018-08-01 04:58:43 +0000
commit940775b9486091ade014396f65ca84f731b38cf8 (patch)
tree13f6ff8076f576570a58b400f27e9017f9d1d6d1 /epan/dissectors/CMakeLists.txt
parent9cf292a30f0098c9abcef57d9242cbc2d00e5075 (diff)
Do most of the RFC 7468 file processing in the dissector.
Have the Wiretap code just do a heuristic test to see if the file looks like a RFC 7468 file and just had the entire blob of raw file data to the caller, with an encapsulation type of WTAP_ENCAP_RFC7468. Have a file-rfc7468.c dissector that processes the lines of the file, displaying all of them. Have it extract the label from the pre-encapsulation boundary line, and, after it's decoded the base64-encoded data lines into a blob of data, try handing the tvbuff with the blob to dissectors that have registered in the "pem.preeb_label" dissector table with the appropriate label value, and hand it to the raw BER dissector only if that fails. This allows some files to have the content dissected as more than just a raw blob of BER-encoded data. Change-Id: I98db9f0beb86e5694fb8e886005a2df4fc96ba71 Reviewed-on: https://code.wireshark.org/review/28914 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index 08df528892..8a079fd6bf 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -622,6 +622,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/file-pcapng.c
${CMAKE_CURRENT_SOURCE_DIR}/file-png.c
${CMAKE_CURRENT_SOURCE_DIR}/file-rbm.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/file-rfc7468.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-2dparityfec.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-3com-njack.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-3com-xns.c