aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorMilan Stute <mstute@seemoo.tu-darmstadt.de>2018-10-25 12:59:54 +0200
committerAnders Broman <a.broman58@gmail.com>2018-11-29 22:12:42 +0000
commit6f2ca9635941ab6922db566a9a7a33e86227ead6 (patch)
tree4d27b7857dce073bf232e093636f99bd6d4f8eab /epan/dissectors/CMakeLists.txt
parentbd3cb6437ffec4d07e47957f2327cda0942c31d5 (diff)
Add Apple Wireless Direct Link (AWDL) dissector
More information on Apple's proprietary AWDL protocol can be found in Milan Stute, David Kreitschmann, and Matthias Hollick. "One Billion Apples' Secret Sauce: Recipe for the Apple Wireless Direct Link Ad hoc Protocol" in ACM MobiCom '18. https://doi.org/10.1145/3241539.3241566 Bug: 15245 Change-Id: I5ce18125b3c957f338909e46f18e30405a3d3941 Reviewed-on: https://code.wireshark.org/review/30413 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index 6a71f84c39..c76739e9ed 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -690,6 +690,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-atmtcp.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-auto_rp.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-avsp.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-awdl.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-ax25.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-ax25-kiss.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-ax25-nol3.c