aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2019-10-03 00:16:22 +0100
committerAnders Broman <a.broman58@gmail.com>2020-08-08 15:14:06 +0000
commitc7728244bb501770c2657e334d719d6c02d1d910 (patch)
treee1384251f148bdd956d36285452048e30c1ccf18 /epan/dissectors/CMakeLists.txt
parent2a832c8a8c44c2a54936176e69172f8b14d3d828 (diff)
http3: add very basic support for HTTP/3 framing
Very rough support for dissecting the framing on unidirectional and bidirectional streams. Support for dissecting QPACK contents will be added later. Thanks to Omer Shapira for identifying an important issue that broke reassembly and blocked proper HTTP/3 support. Bug: 16761 Change-Id: Ib7f87c824f1dca70967b82943e18d5afee39fa0b Reviewed-on: https://code.wireshark.org/review/38084 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index d4a6e231e4..8a160aaedc 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -1182,6 +1182,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-hsrp.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-http.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-http2.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-http3.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-http-urlencoded.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-hyperscsi.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-i2c.c