aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorMikael Kanstrup <mikael.kanstrup@sony.com>2020-02-14 14:28:36 +0100
committerAnders Broman <a.broman58@gmail.com>2020-02-27 04:28:49 +0000
commitc583304dd570097fde4d8a1615b44c0be15e126d (patch)
tree25700f1466da7319d4266339fc898e3c24e25bd8 /epan/dissectors/CMakeLists.txt
parentf8f6ce55defa4b0a69509564deecb31259fc1e74 (diff)
Add TEAP dissector
Initial support for TEAP (Tunnel Extensible Authentication Protocol) defined in RFC7170. Only partial support implemented. Mainly the parts needed to discover the carried EAP payload when establishing IEEE802.11 EAP-TEAP connections. Bug: 16379 Change-Id: Ic2b31d0b871b430792a371cd09926811e350c32b Reviewed-on: https://code.wireshark.org/review/36104 Reviewed-by: Peter Wu <peter@lekensteyn.nl> Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index fcef86f9b9..4f329de0a5 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -1780,6 +1780,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-tdmoe.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-tdmop.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-tds.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-teap.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-teamspeak2.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-teimanagement.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-teklink.c