aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2019-05-08 19:34:54 +0200
committerAnders Broman <a.broman58@gmail.com>2019-05-10 10:44:19 +0000
commit9ddb50f33f86da361e3d56d92ade08f5cc8a44dd (patch)
tree0461238f824f31177ae440c9364d076c288954bd /epan/dissectors/CMakeLists.txt
parent32fa74c08ffdbd26b1e5f8ee9dad60af8b3f1c12 (diff)
BSSMAP: Further decode the GCR (Global Call Reference) field
The BSSMAP LCLS GCR field is specified in 3GPP TS 29.205, which in turn was originally created to augment the ITU-T Q.190x BICC with Mobile specific information elements. Let's add the latter decoding function as a new packet-bicc_mst.c, so it can be used also from other dissectors. For example, GSM MAP also includes GCRs and hence should be modified to use this new decoder. Change-Id: I247d2ccd2d16e996f4fe5d5952ba8a4091a4ffd0 Reviewed-on: https://code.wireshark.org/review/33117 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index dae00cb5f5..3fc3b1e13c 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -262,6 +262,7 @@ set(DISSECTOR_PUBLIC_HEADERS
packet-ber.h
packet-bfd.h
packet-bgp.h
+ packet-bicc_mst.h
packet-bluetooth.h
packet-bssap.h
packet-bssgp.h
@@ -718,6 +719,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-bfcp.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-bfd.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-bgp.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-bicc_mst.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-bitcoin.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-bittorrent.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-bjnp.c