aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Vogt <gitwiresharktv@ist-einmalig.de>2022-06-20 16:38:17 +0200
committerA Wireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2022-06-23 19:40:25 +0000
commit95b01dc4bf32076a4fdffbd035a3396c379e1367 (patch)
tree5765e5561286102bfcd0855de690cb10f0e2d5d7 /epan/dissectors/CMakeLists.txt
parent181a7c7d7d336e823c31d621ec2a5b2e08d7b7de (diff)
GREbond: Add support for Huawei's GRE bonding (RFC8157) control protocol
This dissector is for the control messages of the GRE bonding protocol by Huawei. These messages are encapsulated in GRE and can appear on both/all bonding links. During development, I made heavy use of traffic for Deutsche Telekom Hybrid service. There fore, it also supports the first version which did not have an IEEE assigned ethertype.
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index 7be73e7a19..3847f2532d 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -1149,6 +1149,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-gprs-llc.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-gprscdr.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-gre.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-grebonding.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-grpc.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-gsm_a_bssmap.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-gsm_a_common.c