aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Sarna <sarna@scylladb.com>2020-03-30 16:51:07 +0200
committerMartin Mathieson <martin.r.mathieson@googlemail.com>2020-04-27 14:06:05 +0000
commit6d0863eecbde53b4898ab42908a6f75a4dc65191 (patch)
tree8b14d5960c44ce6f240ba9aa91bd08a028483142 /epan/dissectors/CMakeLists.txt
parent1aba12265eacf5b9a4942f3a7ecdd893f5157a88 (diff)
dissectors: add ScyllaDB dissector
This commit adds a basic dissector for ScyllaDB RPC protocol. ScyllaDB (www.scylladb.com) is a No-SQL database serving multiple client protocols (e.g. CQL). The newly introduced dissector provides a way to inspect Scylla's internal protocol, used by the nodes to communicate with each other - share data, gossip the cluster state, update the schemas, etc. This dissector implements only a shallow dissection of most packets, i.e. recognizing the packet type. Two requests with deeper dissection are MUTATION and READ_DATA, used by I/O operations in the database. Bug: 16471 Change-Id: Ibba8262bd4e5a637b24b3e7846c42c6534ef811b Signed-off-by: Piotr Sarna <sarna@scylladb.com> Reviewed-on: https://code.wireshark.org/review/36633 Petri-Dish: Martin Mathieson <martin.r.mathieson@googlemail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Martin Mathieson <martin.r.mathieson@googlemail.com>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index b656aa57da..fb46521a39 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -1694,6 +1694,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-scsi.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-scte35.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-sctp.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-scylla.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-sdh.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-sdlc.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-sdp.c