aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorAidan MacDonald <amachronic@protonmail.com>2021-10-23 20:58:29 +0100
committerTomasz Moń <desowin@gmail.com>2021-11-17 13:27:56 +0100
commit660dded3830afcb9eab0498aaaf72db69e40b816 (patch)
tree4cc00bbbf98d184dc97737a97fda4aace2a92d99 /epan/dissectors/CMakeLists.txt
parentf748c91bb2ad08b746216842f171c33245424394 (diff)
Refactor USB mass storage class dissector
The existing dissector only handles the Bulk-Only Transport protocol but occupies the USB dissector hooks for all mass storage class traffic. To facilitate alternative protocols like UASP, direct all mass storage class traffic to a stub dissector which will dispatch to the real dissector based on other information, such as the USB interface protocol. Heuristic dissectors are still attached directly to the core USB hooks.
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index 36fcd04e9a..5f45946800 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -1923,6 +1923,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-usb.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-usbip.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-usbll.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-usbms-bot.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-user_encap.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-userlog.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-uts.c