aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorOrgad Shaneh <orgad.shaneh@audiocodes.com>2019-12-10 16:46:25 -0500
committerPeter Wu <peter@lekensteyn.nl>2020-02-13 23:26:15 +0000
commit32679c14bedd01efa6f4cc1598f5b03ecba73d98 (patch)
treeebbafc0e618f4336aaeb0057ac9982ea96c42ae6 /epan/dissectors/CMakeLists.txt
parentc867d271386d0da803a742ea0f8a1bf0071f8d22 (diff)
Introduce AudioCodes Debug Recording (ACDR) dissector
ACDR is a protocol over UDP that is used by AudioCodes devices for recording traffic to and from the device. It adds a header to each packet that contains extra data about the packet. For some packet types (like SIP), it also appends the IP and UDP/TCP headers of the sent/received packet. The dissector unwraps the ACDR header, and displays the packets with the original type (and when available, with the original addresses). Bug: 16275 Change-Id: I19ad90053a2ef73da80881dc5e94aa362de23ea3 Reviewed-on: https://code.wireshark.org/review/35417 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index dfc64b7359..253456ea5a 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -247,6 +247,7 @@ set(DISSECTOR_PUBLIC_HEADERS
file-rbm.h
packet-6lowpan.h
packet-a21.h
+ packet-acdr.h
packet-acp133.h
packet-acse.h
packet-actrace.h
@@ -651,6 +652,7 @@ set(DISSECTOR_SRC
${CMAKE_CURRENT_SOURCE_DIR}/packet-aarp.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-aastra-aasp.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-acap.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/packet-acdr.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-acn.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-acr122.c
${CMAKE_CURRENT_SOURCE_DIR}/packet-actrace.c